summaryrefslogtreecommitdiff
path: root/app-admin/system-config-printer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /app-admin/system-config-printer
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'app-admin/system-config-printer')
-rw-r--r--app-admin/system-config-printer/Manifest2
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.14.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/system-config-printer/Manifest b/app-admin/system-config-printer/Manifest
index c5f88dfcc490..7b125879309a 100644
--- a/app-admin/system-config-printer/Manifest
+++ b/app-admin/system-config-printer/Manifest
@@ -1,3 +1,5 @@
DIST system-config-printer-1.5.13.tar.xz 974532 BLAKE2B 44e748d2fc20edefe58e1c8dd3781aff28af93e57356a9969e051813bf4f04f72c4e895b587e86614df6fb4984a4d610e8e1a1e17777801ae8912b6904679c72 SHA512 f4fbc1b20b35aa5b33bafdffc8a7490cc3c55e0b33bd9e925f1d3e01532c0a7bb87f80a04dd6da6fc492edd9fea74bacb0ce16ff64ceac622722fe1f9a77a6b7
+DIST system-config-printer-1.5.14.tar.xz 1005400 BLAKE2B 23f96a079e568afc098cc505d32b02d1fe14e8e43bf24032c890d8c924f754def194525a8188719873c3c4b693666c1ef83f19b8bbe89846fc2c32ed48abe4da SHA512 5aa0f9f7d3a6e15acc1c2fdc62cc6c10bc686a62fbfd2b97aa61e1d6d1d690019fc461b6db54d6340668f52d52764cc0b2cd59b02b5061b7f44577f2c2b19fe9
EBUILD system-config-printer-1.5.13.ebuild 1942 BLAKE2B 26bd1079a01eebc8f49335d5756f310471b686bfe8966d5b993040c0636d6eaafee272eb8da305b07df0a8880e1db4899fdb61f9cd929ff1c829dc1e07c667f3 SHA512 e25caad24daf23975975b52bf2ea241e06b462573dd0e2129cebb9de467c94e035e5f3e64914d68123d0da8f40276071d9600888992b57ad9b316556a2bf1ab3
+EBUILD system-config-printer-1.5.14.ebuild 1947 BLAKE2B 2d6401f250725a79d029a10b73e08721c37904f2a7a015b8970d00e22a6631607dc06c3b6a186f2145aca6535a474879c5fd9426b91af68e6fcdc79fb215b1e5 SHA512 b7e9155c46dfd20c548cca7538e72aee51214124540d2996c41ea2b770f93418ea5cef87e6cc6ef748ab3cce5e167d7f33a88426e90d05d119d914e30e4cef4e
MISC metadata.xml 463 BLAKE2B 8cc3de37cb766555e89dca64b9be719c3b2885144f08e5a126084e5f8125ff085e9c51705216cd51fb3c66daa29016a790dd606de2b443a7e65f6677f4c46fa4 SHA512 8521e871b99b17ea2bb754dc9bf1b1a49bd32673acce3fe561ec087c5c4bacfbefbf904af1cf5a6ada369e936a0e06a7116074ef622f882e434da7afdee12533
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.14.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.14.ebuild
new file mode 100644
index 000000000000..2ea09c424a65
--- /dev/null
+++ b/app-admin/system-config-printer/system-config-printer-1.5.14.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="xml"
+inherit python-single-r1 systemd xdg
+
+DESCRIPTION="Graphical user interface for CUPS administration"
+HOMEPAGE="https://github.com/OpenPrinting/system-config-printer"
+SRC_URI="https://github.com/OpenPrinting/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnome-keyring policykit"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Needs cups running, bug 284005
+RESTRICT="test"
+
+# Additional unhandled dependencies
+# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
+# python samba client: smbc
+# selinux: needed for troubleshooting
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/glib:2
+ net-print/cups[dbus]
+ virtual/libusb:1
+ >=virtual/udev-172
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/xmlto-0.0.22
+ dev-perl/XML-Parser
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycups[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/urllib3[${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-keyring? ( app-crypt/libsecret[introspection] )
+ policykit? ( net-print/cups-pk-helper )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-nls
+ --with-desktop-vendor=Gentoo
+ --with-udev-rules
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED}"
+ python_optimize
+}