summaryrefslogtreecommitdiff
path: root/app-admin/system-config-printer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /app-admin/system-config-printer
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'app-admin/system-config-printer')
-rw-r--r--app-admin/system-config-printer/Manifest1
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.11-r2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-admin/system-config-printer/Manifest b/app-admin/system-config-printer/Manifest
index 0a80c18c4dee..54c30f9f177a 100644
--- a/app-admin/system-config-printer/Manifest
+++ b/app-admin/system-config-printer/Manifest
@@ -1,4 +1,5 @@
DIST system-config-printer-1.5.11-patchset-01.tar.xz 6948 BLAKE2B effe29c51cbe74fc72566df65f10ab845c9dc1f40ca2966c40be87e19f98046f34311c24b7bc77f471b840e35b0c8eb7754a7c5464d50335c8ab2e2ed0e79afd SHA512 2501bda0e75ea51cc8e14df6b3746a0ea51618919ef35ace849efeded0cddc49e6e3793142d1cd128ce3ce62c21661d5fdb85b19718df07b87a20f5fc641885b
DIST system-config-printer-1.5.11.tar.xz 949816 BLAKE2B 96b41d64e0aa3494b7fc7ed15ac926d833a046ba2880b36b6f5dd4e7508e2bc1fac4cb52c9940c13cec6e34cb8972fbc11fcd5a7df510296444ca08a23f4cb2b SHA512 cc0a6faec0022092e64de3d7ab28669039c93853c6931d26c264f0035486e09ad0af784833e88ee8e3dc1b6f5be9dcf84144a2a6464dfa9711172966fa6a22b4
EBUILD system-config-printer-1.5.11-r1.ebuild 2385 BLAKE2B 662c0baddb0b4118b4a54aff12dce7403f2a8a11856759fc322cbbe1be0869be81767a7791fbc6c12838b57bb0cb77b2f820b4dc57c546fbb9181f4fcf383844 SHA512 e2d9732510cd65a0814540ee1729ebd1bc876c94f30a16a08b4b2e9596e492a0228f8dc1b01cdb01758345206e03c61d3f7ac95b630d2fff2075592f8e530123
+EBUILD system-config-printer-1.5.11-r2.ebuild 2391 BLAKE2B a9ae83182a784c3ad131ab3445a75a5a334a68d95ef78caac0a52be8bd548ef5772adba59161e2c9df1c770c6293f0f58e0474b18e5c51480cecea4d2b5a88e9 SHA512 ce543d1b878d214133efb5452fbd74c53471b562647834e33b108fb81f899022ceb44aa63809c7bc6e9073ce313818173a7c635ff3a5176441f3a3c864231824
MISC metadata.xml 463 BLAKE2B 8cc3de37cb766555e89dca64b9be719c3b2885144f08e5a126084e5f8125ff085e9c51705216cd51fb3c66daa29016a790dd606de2b443a7e65f6677f4c46fa4 SHA512 8521e871b99b17ea2bb754dc9bf1b1a49bd32673acce3fe561ec087c5c4bacfbefbf904af1cf5a6ada369e936a0e06a7116074ef622f882e434da7afdee12533
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.11-r2.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.11-r2.ebuild
new file mode 100644
index 000000000000..3138fdc7de8c
--- /dev/null
+++ b/app-admin/system-config-printer/system-config-printer-1.5.11-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="xml"
+inherit gnome2 python-single-r1 systemd
+
+DESCRIPTION="Graphical user interface for CUPS administration"
+HOMEPAGE="https://github.com/zdohnal/system-config-printer"
+SRC_URI="https://github.com/zdohnal/${PN}/releases/download/${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~asturm/distfiles/${P}-patchset-01.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+SLOT="0"
+
+IUSE="doc gnome-keyring policykit"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Needs cups running, bug 284005
+RESTRICT="test"
+
+# Additional unhandled dependencies
+# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
+# python samba client: smbc
+# selinux: needed for troubleshooting
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/glib:2
+ net-print/cups[dbus]
+ virtual/libusb:1
+ >=virtual/udev-172
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/xmlto-0.0.22
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( dev-python/epydoc )
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ gnome-keyring? ( app-crypt/libsecret[introspection] )
+ policykit? ( net-print/cups-pk-helper )
+"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-auth-dialog.patch
+ "${WORKDIR}"/${P}-libsecret-optional-{1,2}.patch
+ "${WORKDIR}"/${P}-scp-dbus-service-{1,2}.patch
+ "${WORKDIR}"/${P}-typo.patch
+ "${WORKDIR}"/${P}-appdata.patch
+ "${WORKDIR}"/${P}-empty-LC_MESSAGES.patch
+ "${WORKDIR}"/${P}-fdopen-utf8.patch
+ "${WORKDIR}"/${P}-typeerror.patch
+ "${WORKDIR}"/${P}-debugprint-typo.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-nls \
+ --with-desktop-vendor=Gentoo \
+ --with-udev-rules \
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+}
+
+src_compile() {
+ gnome2_src_compile
+ use doc && emake html
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( html/. )
+ gnome2_src_install
+ python_fix_shebang "${ED}"
+}