summaryrefslogtreecommitdiff
path: root/app-admin/sysstat/sysstat-999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-admin/sysstat/sysstat-999999.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-admin/sysstat/sysstat-999999.ebuild')
-rw-r--r--app-admin/sysstat/sysstat-999999.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/app-admin/sysstat/sysstat-999999.ebuild b/app-admin/sysstat/sysstat-999999.ebuild
index b8e79ab247b8..62f6cc193b2b 100644
--- a/app-admin/sysstat/sysstat-999999.ebuild
+++ b/app-admin/sysstat/sysstat-999999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic git-r3 multilib systemd toolchain-funcs
+EAPI=7
+inherit flag-o-matic git-r3 systemd toolchain-funcs
DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
@@ -30,8 +30,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-11.7.3-flags.patch
)
-SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d
-
src_prepare() {
if use nls; then
strip-linguas -i nls/
@@ -52,9 +50,8 @@ src_configure() {
tc-export AR
use static && append-ldflags -static
- sa_lib_dir=/usr/$(get_libdir)/sa \
+ sa_lib_dir=/usr/lib/sa \
conf_dir=/etc \
- rcdir=${SYSSTAT_FAKE_RC_DIR} \
econf \
$(use_enable debug debuginfo) \
$(use_enable lm_sensors sensors) \
@@ -77,9 +74,8 @@ src_install() {
dodoc -r contrib/
- rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service
- rm -f "${D}"usr/share/doc/${PF}/COPYING
+ rm "${D}"/usr/share/doc/${PF}/COPYING || die
}