summaryrefslogtreecommitdiff
path: root/app-admin/syslog-summary
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /app-admin/syslog-summary
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'app-admin/syslog-summary')
-rw-r--r--app-admin/syslog-summary/Manifest2
-rw-r--r--app-admin/syslog-summary/files/syslog-summary-1.14-fix-ignore-code.patch12
-rw-r--r--app-admin/syslog-summary/syslog-summary-1.14-r3.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/syslog-summary/Manifest b/app-admin/syslog-summary/Manifest
index a4d883ce892a..ef8b07c7eb11 100644
--- a/app-admin/syslog-summary/Manifest
+++ b/app-admin/syslog-summary/Manifest
@@ -1,4 +1,6 @@
+AUX syslog-summary-1.14-fix-ignore-code.patch 306 BLAKE2B e319592affd7f13c88cd4ea2ba993050474fa1f96351d0144e20ca0ada5fc4ba5aa5243adc71a99efa12ea189757b05fc76f649688eece6261a0f7697bd3719a SHA512 cc6cdaf03d62a1bda5bcbd4c395ef1fbbc7be7a61ec88df6c7784e14c6a3cf677e58304cf4b5caafe115f7267e38262978a148fe9811bdce0f10966df72c709b
DIST syslog-summary-1.14.tar.gz 7278 BLAKE2B 609e506c099b734be87ba6d6e21f70283d4654ab5c6d3794da71099f3e590d178348c13ab271ddb84682220091adfd702c107bf2dee792419de3ce14d2a9c9db SHA512 db1f0660ad435eea26fc3ec4cd475f5f1b98bb629495707741077e52aef88fe8bff4a318bb5b0821e57ccfa0646454c6825a5a4fc1fb4b73ea67cbd4defef277
EBUILD syslog-summary-1.14-r1.ebuild 766 BLAKE2B 036754524dd9c11b985c2ef5777636aba3be7bc92b1ed430cc00cf1ac93701f442354dfe9b12e7a0dcbfca4625a7b6fceea2cb218e9ad3fa2a42f39e098bda39 SHA512 f865914965a0ea4f6db355429c4ffedc768c491c9d7f93a6668422bc3e307be31465fe003462bbf45c73857b292110132bd4499d023040516a1c614fb716a549
EBUILD syslog-summary-1.14-r2.ebuild 944 BLAKE2B ef4dde4b5da0ce5ae1b28e9200d2d51fbca075f30bb72a6f1bb49104d980da37ea44c872901ee207e392cf5f06a3f4a9a5bc032da5f4d50a9fc8805c12366c66 SHA512 47fe494a2bc164750e4804b6c6e8dfa9328b072ab9e7ca0e77e1f2bc4d253387f4e3ed13bfd1d84cc729d15f71faf58660484803ae2c38dcd61d77c2ef79ff5a
+EBUILD syslog-summary-1.14-r3.ebuild 991 BLAKE2B 9086206934c07f3d810faec448a65cd24492bdd986d7832c95579aaba61136595b6b9c4f4d8fd5d406e32cd15ad9369d095b2e3c68e762267c894738bff5be6f SHA512 c127aa0387176e078d31b46729c9b437e4537b2821ec7b4eda4d7c742e31e014ce1d33f3d3ef3666ccee1de0a21759f27f5feaaf778ee0f26ee703bd26ddd94b
MISC metadata.xml 464 BLAKE2B 862ef04e25fe1aa6609e2ea68c9d61a9c201d43ffab9db6a02244ca9192f4fd11a1f1f4e4d6f7e365660c4043b28a959d5da9783f3c6f0ed4f69eb625784763c SHA512 64073e0ef15c4fbe057f51c09505ea3db8d5e1427c2d581b55137e7fba37f5fef13103cfe4d0e58c74052601d4bae0ed26e36346d497653ea080fe5649f956eb
diff --git a/app-admin/syslog-summary/files/syslog-summary-1.14-fix-ignore-code.patch b/app-admin/syslog-summary/files/syslog-summary-1.14-fix-ignore-code.patch
new file mode 100644
index 000000000000..b66a0ad51ceb
--- /dev/null
+++ b/app-admin/syslog-summary/files/syslog-summary-1.14-fix-ignore-code.patch
@@ -0,0 +1,12 @@
+diff --git a/syslog-summary b/syslog-summary
+index abf6381..65608cb 100755
+--- a/syslog-summary
++++ b/syslog-summary
+@@ -198,6 +198,7 @@ def summarize(filename, states):
+ if DEBUG:
+ print "Ignoring: %s" % line
+ line = file.readline()
++ continue
+
+ date, rest = split_date(line)
+ if date:
diff --git a/app-admin/syslog-summary/syslog-summary-1.14-r3.ebuild b/app-admin/syslog-summary/syslog-summary-1.14-r3.ebuild
new file mode 100644
index 000000000000..75c1c04b2464
--- /dev/null
+++ b/app-admin/syslog-summary/syslog-summary-1.14-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Summarizes the contents of a syslog log file"
+HOMEPAGE="https://github.com/dpaleino/syslog-summary"
+SRC_URI="https://github.com/downloads/dpaleino/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-ignore-code.patch" )
+
+src_prepare() {
+ python_fix_shebang -f syslog-summary
+
+ sed -i -e 's:python-magic:sys-apps/file[python]:' "syslog-summary" || die
+
+ # Sadly, the makefile is useless for us.
+ rm Makefile || die
+
+ default
+}
+
+src_install() {
+ dobin syslog-summary
+ einstalldocs
+ doman syslog-summary.1
+
+ insinto /etc/syslog-summary
+ doins ignore.rules
+}
+
+pkg_postinst() {
+ elog "install sys-apps/file[python] to enable processing"
+ elog "of gzip compressed logfiles"
+}