summaryrefslogtreecommitdiff
path: root/app-admin/supervisor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 20:03:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 20:03:07 +0000
commitec9f79e1d3358df31a704f16a76a269ccceae2b2 (patch)
tree5982c029d09bc9e396ad5ead3d99c99ed6a58322 /app-admin/supervisor
parent9aefa814d833d6bdd1bdbc7d0f44d5680c9beaa8 (diff)
gentoo auto-resync : 24:12:2022 - 20:03:07
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/Manifest2
-rw-r--r--app-admin/supervisor/supervisor-4.2.5.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index 946e8d25da45..8c614e28b770 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -4,6 +4,8 @@ AUX supervisord.conf 2525 BLAKE2B d36d6ef6b952a99ccfd61976c21eb54922555db4802288
AUX supervisord.service 404 BLAKE2B 87c99a2b388befb04f1d8e3442a5c0b6d802837047c45da2bb7017631bf4af4b858bc4d7964f1d64937e331728884bc21e62e9d01b11cca46aaea389372c6bad SHA512 0fe777d1f0bf70dc9b49132102ac90083261321850f80e9e323459c894c55f722ab8470eba3ba7bb35a9d69ad411a3247546066d6cba5801c9b289350ea4bed5
DIST supervisor-4.2.2.tar.gz 463657 BLAKE2B 766feffcbd70b575b6b7dfd6ed98e3510e0fd9362c423b677d44a2b5dd23ded14a349a279d3d28d4fd9e04a2175c8f00e24c07df310b61d34c7f69f60d26a4ac SHA512 f787206e6c6a5d3dfc4284974a4a87cbcaeac0c705afb2b8eae53f066413bd9e68095c5309e29625e01469a4748613370e1ac0d7be84b9d72c3623244bdd2eb3
DIST supervisor-4.2.4.tar.gz 465151 BLAKE2B 91b99a64950dc874bdc008ba53ca8b1962cc34981fee27c2fd82956d73ace9eaaf91439ef6be40530c4860fe1eee193e19b51ab81050f7368aa7d31f8444c785 SHA512 38c55aeadb8664337b667aad891a3a2134ae4af88e90d636054e6be9aebc8a3ef87d79d15fcafd2b9966af562deeedc96ac3730bde9439dde30208f0a874f2d7
+DIST supervisor-4.2.5.tar.gz 466073 BLAKE2B 54b45c824a1ad2960b04ca4ca9e54337f8c4da1a13008b559103f9efb9043588e72b3ee97c41218eb9252606d717575ad2615d12136047734f83d843d0a63bfa SHA512 ea80c8c91356646deccf20735e065fd9b341f3be6d56838d333989297a912b0a59142338925b2eb08690e038f0617814e03447673701a19093aa483432ce6d41
EBUILD supervisor-4.2.2.ebuild 1630 BLAKE2B 0d44a0cae21becac83a76e676ab725d5e9c3e625d1990bf0f1a08298fae0b60ff8328d68e6b4a1fa64e2eeeb70eb01076690c6bf4c4c290e8941851dad0a9447 SHA512 2f0aee14c668efcfbd85d29b698b12ad483fd8164978ae901cd3ef296c64149af8f10f53a0163fa568b49d0c9d513c54f8252583e5604903107e26379add17ae
EBUILD supervisor-4.2.4.ebuild 1424 BLAKE2B 8b2d1e7f596e6c092639e88b98514a098d603019c8b5eccbcc0bd6f5eb9ddf96f29df1289e33bb11a657afafbe5791e25949e37629bdbf70bd82cb914328a9d6 SHA512 ef6224e54e7e1e09b1285fb7fe682646a7c378ea8e470ed67e4e769f4a3e56fde50195900b9b01611cf5fc2e923e5184ba0c3103f790592d864229e207189120
+EBUILD supervisor-4.2.5.ebuild 1423 BLAKE2B 7d956bceababaf8eb46775078c2dd2b0daf69c7a0c8a522e3d275d5cc791106816725f4c23f21f8986845e77f73196a80a17b2e32049f987e51023cd4fbae5a4 SHA512 68166eea54073f5383de9fc52e3d0ef2e9d99ecf3353eec9994ec00d1e4a634e9a3dd34695479e445f5b8ca0a39c6881f72aa8a8405461baa2fde8b8a8c87c45
MISC metadata.xml 624 BLAKE2B 6cb179a9284e7898dcfc4423e12e04d7bd4e805930f8f4e79e3528153180146aeb606040d087e3c5d127e6d7e3b42cbbd6f4b7c1bb2ad7fa414bf90a40a76502 SHA512 dfe5b6abb493cb69a2a2b2d93fbf9c66b4f21ca5d83d76a2da5066f3625a945c1834e876ce8b8b4368cec3e34a81003f7be47898b5e2bdbe796714ea8291f63a
diff --git a/app-admin/supervisor/supervisor-4.2.5.ebuild b/app-admin/supervisor/supervisor-4.2.5.ebuild
new file mode 100644
index 000000000000..de4148c5f9bd
--- /dev/null
+++ b/app-admin/supervisor/supervisor-4.2.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="acct-group/supervisor"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newinitd "${FILESDIR}/init.d-r2" supervisord
+ newconfd "${FILESDIR}/conf.d-r1" supervisord
+ dodoc supervisor/skel/sample.conf
+ keepdir /etc/supervisord.d
+ insinto /etc
+ doins "${FILESDIR}/supervisord.conf"
+ keepdir /var/log/supervisor
+ systemd_dounit "${FILESDIR}/supervisord.service"
+}
+
+pkg_preinst() {
+ fowners :supervisor /var/log/supervisor
+ fperms 750 /var/log/supervisor
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
+ elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
+ elog ""
+ elog "By default, only members of the supervisor group can run supervisorctl."
+ fi
+}