summaryrefslogtreecommitdiff
path: root/app-admin/supervisor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /app-admin/supervisor
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/Manifest2
-rw-r--r--app-admin/supervisor/supervisor-4.2.2.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index 95f4b9461916..6f1c8438761b 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -4,6 +4,8 @@ AUX supervisord.conf 2525 BLAKE2B d36d6ef6b952a99ccfd61976c21eb54922555db4802288
AUX supervisord.service 404 BLAKE2B 87c99a2b388befb04f1d8e3442a5c0b6d802837047c45da2bb7017631bf4af4b858bc4d7964f1d64937e331728884bc21e62e9d01b11cca46aaea389372c6bad SHA512 0fe777d1f0bf70dc9b49132102ac90083261321850f80e9e323459c894c55f722ab8470eba3ba7bb35a9d69ad411a3247546066d6cba5801c9b289350ea4bed5
DIST supervisor-4.2.0.tar.gz 456056 BLAKE2B 51b66cfc34505b937c47c9b510d81bcc777b9372fdeb2e08fc25153d2718cd2682258b812630160954587ceb992e1a528cdd5bf0d270139f7ffac9463ac2f015 SHA512 626d806f4b03be7cbff795afd1bdb3ff5ca5ecf44f035909ea1aa9360da9fa3047b2fe05543190bf1442f01dcdd403be19fcd907519bf7e26615900bc4bf9d0f
DIST supervisor-4.2.1.tar.gz 460935 BLAKE2B 0c65f904599c1e8a04cd3a71085e2b2a5460691c2bfd790d3b7c10449cae08472bcd72a870cbe611801434624f405ea3e245f156cab93f25a8df784b58d948d7 SHA512 c560ef959f8d580fb20c1812aa2a838c9feaeb3726a754e8084fa8c7406ff9258139b55b081558b8d8f33e4672cdfad40695170f55412a5e85a6c1aed0f11657
+DIST supervisor-4.2.2.tar.gz 463657 BLAKE2B 766feffcbd70b575b6b7dfd6ed98e3510e0fd9362c423b677d44a2b5dd23ded14a349a279d3d28d4fd9e04a2175c8f00e24c07df310b61d34c7f69f60d26a4ac SHA512 f787206e6c6a5d3dfc4284974a4a87cbcaeac0c705afb2b8eae53f066413bd9e68095c5309e29625e01469a4748613370e1ac0d7be84b9d72c3623244bdd2eb3
EBUILD supervisor-4.2.0.ebuild 1715 BLAKE2B 39d6abc4da52b99db867c4f950a1f58ea4dea07b2f08c0de1963bd53059168d5831944ec56f2a99a129588947caf6400af4190ab1a5ead4c032e06e19e9f5e6a SHA512 fcae1d9fba0ddfbf13c93615e2f87322688723d91c8b8e47a999ae1efd3f8e64fb1d4bb1dc4036ce750ef6f4c60f0ecc35e23ac5905f224843852ccfbf86a8e4
EBUILD supervisor-4.2.1.ebuild 1479 BLAKE2B f42a9c81f3d121288a5fea58b63dccbb58da73e69d8540701afe40df8765bdce9ad690ab674ed9b0ee61f4c43f898305b774be89123e7d0ae624603bd37e9cdf SHA512 0eb84905941c210c4b5ea22f1759a8e88aa0d624dea14ede0596b4773462f1a6da4b794de4d551bf4330a6399b760be285f47ba269ed17623cba76b93e82bc41
+EBUILD supervisor-4.2.2.ebuild 1631 BLAKE2B 2198953bf9658adf15ff2075c15267acb5d9b33bd5894ef7fe62c5aa935a402a69ab45936e330f65aa2ab9938d4951ea30ea3514411f2d7083d81bb95b9449fc SHA512 b7750e6d8dd48557b06555ced6cbe545e9df26101c6983cea3e83928698bd2d34b1eb98c0ede5d98d79afebf38e34a93d483e710143099cd71700bedb241d60d
MISC metadata.xml 623 BLAKE2B dc7acae3a83fce87bdaf98f65ba4ac2434e0344faeb8ad302dcba5be3a59f2b6ffa9d85338ad432100d5e1017e40bbeb606724a214097e14bcc7082eb331986a SHA512 f05e62f68c51fe2bab054d03b3a902682eaaa133de08ac558a92736868dcc8049d1f27828e3ecae8f5f64b038bb8a322e58c90401e6fe01d215941e1507076e8
diff --git a/app-admin/supervisor/supervisor-4.2.2.ebuild b/app-admin/supervisor/supervisor-4.2.2.ebuild
new file mode 100644
index 000000000000..281756fef94d
--- /dev/null
+++ b/app-admin/supervisor/supervisor-4.2.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="acct-group/supervisor"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # The workaround can be dropped once this is merged:
+ # https://github.com/Supervisor/supervisor/pull/1413
+ sed -i "/ setup.py test/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newinitd "${FILESDIR}/init.d-r2" supervisord
+ newconfd "${FILESDIR}/conf.d-r1" supervisord
+ dodoc supervisor/skel/sample.conf
+ keepdir /etc/supervisord.d
+ insinto /etc
+ doins "${FILESDIR}/supervisord.conf"
+ keepdir /var/log/supervisor
+ systemd_dounit "${FILESDIR}/supervisord.service"
+}
+
+pkg_preinst() {
+ fowners :supervisor /var/log/supervisor
+ fperms 750 /var/log/supervisor
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
+ elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
+ elog ""
+ elog "By default, only members of the supervisor group can run supervisorctl."
+ fi
+}