summaryrefslogtreecommitdiff
path: root/app-admin/sud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/sud
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/sud')
-rw-r--r--app-admin/sud/Manifest5
-rw-r--r--app-admin/sud/files/sud-1.3-fix-build-system.patch30
-rw-r--r--app-admin/sud/files/sud.rc620
-rw-r--r--app-admin/sud/metadata.xml14
-rw-r--r--app-admin/sud/sud-1.3-r1.ebuild36
5 files changed, 105 insertions, 0 deletions
diff --git a/app-admin/sud/Manifest b/app-admin/sud/Manifest
new file mode 100644
index 000000000000..da3615d7568d
--- /dev/null
+++ b/app-admin/sud/Manifest
@@ -0,0 +1,5 @@
+AUX sud-1.3-fix-build-system.patch 649 BLAKE2B 00563b734e50ef85636603e09b32f9db3ad0d072aac61291ae0a0447cbdf2aa04dd40ac0d37e0d03147dac242bf4251eb4c1cbb9b3897008b9fb3e6e06622374 SHA512 9c8151b09d9a1cb06a523c9ddc34ddf18adcc1a45c89805f9c8865a69890810403e7e6b5d9fe6d034f3f68700d88044ce318dd1345ec5843540a404dc54d4e34
+AUX sud.rc6 387 BLAKE2B a1eef9ef30a73c15ea8daf2f2a266cacbcf38dfc2fda1e481b9693c24c5fe5ba726a9154b8dc4a072aa008d5d96ec820f8b1dff375b16ef28f5b5230961fbac1 SHA512 07feba04e36df02e5cab6260f5943d4a72c3549a604d9db33a2f4734b39a60a3514899c0831bf1fe5ce073889989d42f0ae64d1f7bb0735fca7fd2584887364b
+DIST sud-1.3.tar.gz 117542 BLAKE2B e9d28c119e25d3cf0434d10c04d34fbdd0a52fbea84ee09b2dc835ec9eabf30fc91895fd691febbf57590b790febe04b1b45d354f7e2fcab513608de85419746 SHA512 54b58b54e665133dcc40f00708a929bc038df1e2ce18514d830e3f3f823110bd27a209771fc378c2bcd372692e168f55150f12893e2fbd433b51e2173dbd410e
+EBUILD sud-1.3-r1.ebuild 697 BLAKE2B 8f4b85dfc0efbbbe4e63627f22e6e98eb11aeda2a95f8a486cfd7fdb1bc614a3b15a9c6e6fde6a0012606252a4a1a8f3bd26b8fb0176a438eb421ee60134bb15 SHA512 0eaa293326637f1456527a97d68118471bc897643ad6766c19f4c7828b31c23648dffc73827e429555c06727c58d5330d04cd36ad48b0d34d3568060ec5ce87a
+MISC metadata.xml 719 BLAKE2B 5e27e4bdaf382f590f9f5eab598c94e62ac353e0694e3e7094f37637dfc3201e8f23a52d2c2d7f9bfffb574b59838bdb41ebc746a389ebb8a6e89ac0fec2ee9d SHA512 94b453b02af38033f480fa0cd38b6614f4f972a1f2f826e56eda1668db212a31bd6643146f40ba220f77e748c6ba29935527b0a363fcc3cb87e617cfc2ee5938
diff --git a/app-admin/sud/files/sud-1.3-fix-build-system.patch b/app-admin/sud/files/sud-1.3-fix-build-system.patch
new file mode 100644
index 000000000000..5937d3f0a8e6
--- /dev/null
+++ b/app-admin/sud/files/sud-1.3-fix-build-system.patch
@@ -0,0 +1,30 @@
+--- a/login/Makefile.am
++++ b/login/Makefile.am
+@@ -2,5 +2,5 @@
+ ilogin_SOURCES = login.c
+ ilogin_CFLAGS = -Wall
+
+-install-data-hook:
+- chmod 500 $(sbindir)/ilogin
++install-exec-hook:
++ chmod 500 $(DESTDIR)$(sbindir)/ilogin
+--- a/su/Makefile.am
++++ b/su/Makefile.am
+@@ -4,5 +4,5 @@
+
+ INCLUDES = -I../sud
+
+-install-data-hook:
+- chmod 555 $(bindir)/suz
++install-exec-hook:
++ chmod 555 $(DESTDIR)$(bindir)/suz
+--- a/sud/Makefile.am
++++ b/sud/Makefile.am
+@@ -7,5 +7,5 @@
+ #INCLUDES = -I..
+ CLEANFILES = conf_lexer.c conf_parser.h conf_parser.c
+
+-install-data-hook:
+- chmod 500 $(sbindir)/sud
++install-exec-hook:
++ chmod 500 $(DESTDIR)$(sbindir)/sud
diff --git a/app-admin/sud/files/sud.rc6 b/app-admin/sud/files/sud.rc6
new file mode 100644
index 000000000000..068acf776173
--- /dev/null
+++ b/app-admin/sud/files/sud.rc6
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting sud"
+ start-stop-daemon --start --quiet --pidfile /var/run/sud.pid \
+ --exec /usr/sbin/sud
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping sud"
+ start-stop-daemon --stop --quiet --pidfile /var/run/sud.pid
+ eend $?
+}
diff --git a/app-admin/sud/metadata.xml b/app-admin/sud/metadata.xml
new file mode 100644
index 000000000000..39516e080887
--- /dev/null
+++ b/app-admin/sud/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>lu_zero@gentoo.org</email>
+</maintainer>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+<longdescription>
+sud (superuser daemon) permits a user to switch to root privileges and to use a suid program in a nosuid environment. It is based on a client/server model and on the ability to pass file descriptors between processes. sud permits you to choose your authentication method, and your effective credentials will be checked by using a Unix domain socket.
+</longdescription>
+</pkgmetadata>
diff --git a/app-admin/sud/sud-1.3-r1.ebuild b/app-admin/sud/sud-1.3-r1.ebuild
new file mode 100644
index 000000000000..7c72435d9c4d
--- /dev/null
+++ b/app-admin/sud/sud-1.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A daemon to execute processes with special privileges in a nosuid environment"
+HOMEPAGE="http://s0ftpj.org/projects/sud/index.htm"
+SRC_URI="http://s0ftpj.org/projects/sud/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3-fix-build-system.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -D_GNU_SOURCE
+ default
+}
+
+src_install() {
+ default
+
+ doman ilogin.1 sud.1 suz.1
+ insinto /etc
+ doins miscs/sud.conf*
+ newinitd "${FILESDIR}"/sud.rc6 sud
+}