summaryrefslogtreecommitdiff
path: root/app-admin/selint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-admin/selint
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-admin/selint')
-rw-r--r--app-admin/selint/Manifest4
-rw-r--r--app-admin/selint/metadata.xml11
-rw-r--r--app-admin/selint/selint-1.1.0.ebuild39
-rw-r--r--app-admin/selint/selint-9999.ebuild39
4 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/selint/Manifest b/app-admin/selint/Manifest
new file mode 100644
index 000000000000..aacb85723b5d
--- /dev/null
+++ b/app-admin/selint/Manifest
@@ -0,0 +1,4 @@
+DIST selint-1.1.0.tar.gz 283926 BLAKE2B 0908f8830ce4b569c54e8c025dd92c39af59172fee0b8061f5b8cdaf61222979a78c3726a5647af9161ce7e4a7ddd5bee64772afecd2024368afa76294b3d317 SHA512 3af358e0f42a285a0360ce2b4db9014ef1e4f0b792623007f88cf510799080975d9e44817e8911bbd32b141704a7fd11e1b4d8f91e124d0fa91c38f71a978c91
+EBUILD selint-1.1.0.ebuild 777 BLAKE2B 01aefb1c3a19bee5325c75b318000d99f159bf23edc1e399c769c3eda57c7361a6ac87e3837ae79573f588450710b72183ad1b51158817b068a4852eaac7420b SHA512 495108a5bd26315c85f092b0880e3703b1207e45770a59a0cbdeaa68d3c8fbdffd508b229776587d71d4841721c75af919967fa02e27df9af82a87ede9784cbb
+EBUILD selint-9999.ebuild 777 BLAKE2B 01aefb1c3a19bee5325c75b318000d99f159bf23edc1e399c769c3eda57c7361a6ac87e3837ae79573f588450710b72183ad1b51158817b068a4852eaac7420b SHA512 495108a5bd26315c85f092b0880e3703b1207e45770a59a0cbdeaa68d3c8fbdffd508b229776587d71d4841721c75af919967fa02e27df9af82a87ede9784cbb
+MISC metadata.xml 335 BLAKE2B ab88b7d7fedc27d0ba41b77fc133a0ad8b42aa295bb5b64c5bb4924d8081cb1ac3480b07d7c8a04ff8da1c49f47983e33a63cef3de08baac4cb448d656ec6cb9 SHA512 e94ae02402e90d9475fd328454223fa95714c3292877a9cc31e98c393f59dde7ddd9be34afe8b2f2d318105794ca3faa7617166d123259d147115619b14d7d12
diff --git a/app-admin/selint/metadata.xml b/app-admin/selint/metadata.xml
new file mode 100644
index 000000000000..80f8686d2a8d
--- /dev/null
+++ b/app-admin/selint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>selinux@gentoo.org</email>
+ <name>SELinux Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">TresysTechnology/selint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/selint/selint-1.1.0.ebuild b/app-admin/selint/selint-1.1.0.ebuild
new file mode 100644
index 000000000000..592cb7fbdf8f
--- /dev/null
+++ b/app-admin/selint/selint-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Policy Analysis Tools for SELinux"
+HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
+else
+ SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/confuse:=
+ dev-libs/uthash"
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with test check)
+}
diff --git a/app-admin/selint/selint-9999.ebuild b/app-admin/selint/selint-9999.ebuild
new file mode 100644
index 000000000000..592cb7fbdf8f
--- /dev/null
+++ b/app-admin/selint/selint-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Policy Analysis Tools for SELinux"
+HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
+else
+ SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/confuse:=
+ dev-libs/uthash"
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with test check)
+}