summaryrefslogtreecommitdiff
path: root/app-admin/ryzen_monitor/ryzen_monitor-1.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /app-admin/ryzen_monitor/ryzen_monitor-1.0.4-r1.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'app-admin/ryzen_monitor/ryzen_monitor-1.0.4-r1.ebuild')
-rw-r--r--app-admin/ryzen_monitor/ryzen_monitor-1.0.4-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/ryzen_monitor/ryzen_monitor-1.0.4-r1.ebuild b/app-admin/ryzen_monitor/ryzen_monitor-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..f7b5d30fab96
--- /dev/null
+++ b/app-admin/ryzen_monitor/ryzen_monitor-1.0.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+SRC_URI="https://github.com/hattedsquirrel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Monitor power information of Ryzen processors via the PM table of the SMU "
+HOMEPAGE="https://github.com/hattedsquirrel/ryzen_monitor"
+
+SLOT="0"
+LICENSE="AGPL-3"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-admin/ryzen_smu"
+
+PATCHES=(
+ "${FILESDIR}"/fix-Makefile.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/ryzen_monitor
+}