summaryrefslogtreecommitdiff
path: root/app-admin/rasdaemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /app-admin/rasdaemon
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'app-admin/rasdaemon')
-rw-r--r--app-admin/rasdaemon/Manifest3
-rw-r--r--app-admin/rasdaemon/metadata.xml18
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.0.ebuild39
3 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/Manifest b/app-admin/rasdaemon/Manifest
new file mode 100644
index 000000000000..714fc0b86093
--- /dev/null
+++ b/app-admin/rasdaemon/Manifest
@@ -0,0 +1,3 @@
+DIST rasdaemon-0.6.0.tar.bz2 361721 BLAKE2B af992c810024df4f553727b4aff4f4f1d41cb3f7e458ac91916ccbac6815b6ade697f0c49bf1e072205c7f872cfc9c2f7223fe0d3f090064ffaa0bab002d4f67 SHA512 cb363ee9968dab10951077edea6558adc235c2ba1a57294ccf2d483c49af3366bcec0a5857fe2b475a5407de850f706c44bfe4d8a80bcfb53b1c7e2d101ba72f
+EBUILD rasdaemon-0.6.0.ebuild 723 BLAKE2B 03c921e0ef2eb1047410c4c15299a1141325fa00ed6f3145197189baa9b4461527718e14b258da0ad4ab5b0fc4abeec0ecaf50ebdfb83bcdb507e2afed59346c SHA512 492b51108bd5349a88e71b78c76125ed2ba1c020d8e96eef161d763ad798238bc8e03dd852ccb6c266acb5255c32599754c4c917f7a000e7d2257594b48128c4
+MISC metadata.xml 871 BLAKE2B c9b484c2fd3019681f9c335fc046c7718c35bcafd9fa46f59328c68fb4404571818b861cb938bcb00fa08a164688a58735d7db27e73120597cd114a3a39acaba SHA512 1815bc3a92340071b40de8129441bbf55fee7edbec94f5337d6a9b42311cc3c1d898598d0756b60b56d804629700a2c0109362933acf5442a74097e752b24935
diff --git a/app-admin/rasdaemon/metadata.xml b/app-admin/rasdaemon/metadata.xml
new file mode 100644
index 000000000000..2e59b91513af
--- /dev/null
+++ b/app-admin/rasdaemon/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Rasdaemon is a RAS (Reliability, Availability and Serviceability) logging tool.
+It currently records memory errors, using the EDAC tracing events.
+EDAC is drivers in the Linux kernel that handle detection of ECC errors
+from memory controllers for most chipsets on i386 and x86_64 architectures.
+EDAC drivers for other architectures like arm also exists.
+This userspace component consists of an init script which makes sure
+EDAC drivers and DIMM labels are loaded at system startup, as well as
+an utility for reporting current error counts from the EDAC sysfs files.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.0.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.0.ebuild
new file mode 100644
index 000000000000..7bb3e34c6e73
--- /dev/null
+++ b/app-admin/rasdaemon/rasdaemon-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="Reliability, Availability and Serviceability logging tool"
+HOMEPAGE="http://www.infradead.org/~mchehab/rasdaemon/"
+SRC_URI="http://www.infradead.org/~mchehab/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gettext
+ dev-db/sqlite
+ sys-apps/dmidecode
+"
+
+src_configure() {
+ econf --enable-mce \
+ --enable-aer \
+ --enable-sqlite3 \
+ --enable-extlog \
+ --enable-abrt-report \
+ --enable-non-standard \
+ --enable-hisi-ns-decode \
+ --enable-arm
+}
+
+src_install() {
+ default
+ systemd_dounit misc/*.service
+}