summaryrefslogtreecommitdiff
path: root/app-admin/quickswitch/quickswitch-1.05.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/quickswitch/quickswitch-1.05.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/quickswitch/quickswitch-1.05.ebuild')
-rw-r--r--app-admin/quickswitch/quickswitch-1.05.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/quickswitch/quickswitch-1.05.ebuild b/app-admin/quickswitch/quickswitch-1.05.ebuild
new file mode 100644
index 000000000000..24b21cea6b25
--- /dev/null
+++ b/app-admin/quickswitch/quickswitch-1.05.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to switch network profiles on the fly"
+SRC_URI="mirror://sourceforge/quickswitch/${P}.tar.gz"
+HOMEPAGE="http://quickswitch.sf.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc s390 amd64"
+IUSE="ncurses"
+
+DEPEND=">=dev-lang/perl-5.6.0"
+RDEPEND="ncurses? ( dev-perl/CursesWidgets )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.05-fix-paths.patch )
+
+src_install() {
+ dobin switchto
+ use ncurses && dobin switcher
+
+ insinto /etc/quickswitch
+ newins switchto.conf switchto.conf.sample
+
+ einstalldocs
+}