summaryrefslogtreecommitdiff
path: root/app-admin/qtpass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-01 06:30:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-01 06:30:58 +0000
commitc4d4d544a37efc45bd5482e62e1fcdbe7d5993d3 (patch)
treee97ec8b6356535412a838039bf7874aef3129f50 /app-admin/qtpass
parent2e36bcecf24a3f583ae8f27b71ba13b3cfd39778 (diff)
gentoo auto-resync : 01:01:2025 - 06:30:57
Diffstat (limited to 'app-admin/qtpass')
-rw-r--r--app-admin/qtpass/Manifest3
-rw-r--r--app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-buildfix.patch23
-rw-r--r--app-admin/qtpass/qtpass-1.4.0-r1.ebuild (renamed from app-admin/qtpass/qtpass-1.4.0.ebuild)31
3 files changed, 43 insertions, 14 deletions
diff --git a/app-admin/qtpass/Manifest b/app-admin/qtpass/Manifest
index bc235b43a269..82b768e4a904 100644
--- a/app-admin/qtpass/Manifest
+++ b/app-admin/qtpass/Manifest
@@ -1,3 +1,4 @@
+AUX qtpass-1.4.0-qt-6.8-buildfix.patch 691 BLAKE2B 8336eb26131e134389d3db751a5dcbf2375cd9569cbf3f7582fe9cb6ef6f08c1e2993c8d4a006e71cae55e5f8c13d8c58edaf1b2b1cdc9592c2c764514066630 SHA512 e80bc14d987e95c9a7160d5ad12579a5f43fa3671f879d5779482ce932a522bb4390792a00f03c9d234a19d43e6953ac1838a5db59347d881ec7762c0bb04870
DIST qtpass-1.4.0.tar.gz 581368 BLAKE2B 12bf414ea781bad34d97fe28ae39f44e17812039f0d798162b6d875918f20a1583f7a53a1e98ed917edf41c15709c7693c7651205c5e4ec85860ee773350f075 SHA512 47c1284c10e0d8a3bf63c049fc29d785d1a53bef6f183bbe22efebf466371dd454a6e43c944739f487d609f3cde188701ba538e9cb8e2c7e5530f8fa6f992625
-EBUILD qtpass-1.4.0.ebuild 1286 BLAKE2B 09bb22e6563011d514c6714c567c2480e5c5e4ab797c449ea3931e614a498c206f5263804a7f926d49d672fcda5ef255c90ef7f379273d9e1902b1d7384fa5b5 SHA512 3dda3b75abc10177855ba6a80da3a8557e95bdd20398ad2b7caf696ab5f7a271a781e47944ff9f1db9e3ff22db7ad122fba8f8d2d7659896ba103a14bfcabcad
+EBUILD qtpass-1.4.0-r1.ebuild 1311 BLAKE2B ee3421016ccc0d4f94b105952c10df98c60f32d8974ed66c61213a0eb907f55e35305b009c9dc1add0fc135de832037dfec17388ff6bbf80992f1cce027881b5 SHA512 54b8d643f51fc62593cc70aa678bfb9685735ce48544f703b435bff1e6d2b117ca790b7dc9296461bcc00f4653f9f72debb747b030e0e746332477c4863719d3
MISC metadata.xml 485 BLAKE2B 526a8203c5a8601f6bdae7fcc71fb26a6def402406493ebf95869624f8cea44a09fe2c23a041adebcd1bc5bc4ac9c64b2c33725b7d6d24bbf4f415926468a0ce SHA512 bc1c8273227625672ebfce619956a342dc3c74d412a16383c035e88b289a8dad9383ab00c9c5bd4f368dd8fefdad025b0d4f7c209b84251b0e26e16ef4149eef
diff --git a/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-buildfix.patch b/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-buildfix.patch
new file mode 100644
index 000000000000..c996cb9bf8e7
--- /dev/null
+++ b/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-buildfix.patch
@@ -0,0 +1,23 @@
+From c3d04090260edd77e56c0602f264d923b236c42f Mon Sep 17 00:00:00 2001
+From: Arthur Bols <arthur@bols.dev>
+Date: Tue, 5 Nov 2024 17:20:56 +0100
+Subject: [PATCH] fix: add missing QDirIterator include
+
+Added missing include for QDirIterator in mainwindow.cpp to resolve compilation
+errors introduced with Qt 6.8.
+---
+ src/mainwindow.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/mainwindow.cpp b/src/mainwindow.cpp
+index 66b87dc2..691b8593 100644
+--- a/src/mainwindow.cpp
++++ b/src/mainwindow.cpp
+@@ -19,6 +19,7 @@
+ #include <QCloseEvent>
+ #include <QDesktopServices>
+ #include <QDialog>
++#include <QDirIterator>
+ #include <QFileInfo>
+ #include <QInputDialog>
+ #include <QLabel>
diff --git a/app-admin/qtpass/qtpass-1.4.0.ebuild b/app-admin/qtpass/qtpass-1.4.0-r1.ebuild
index d942091a7152..e6a4bd5f91d9 100644
--- a/app-admin/qtpass/qtpass-1.4.0.ebuild
+++ b/app-admin/qtpass/qtpass-1.4.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit desktop qmake-utils virtualx
+inherit desktop qmake-utils
DESCRIPTION="Multi-platform GUI for pass, the standard unix password manager"
HOMEPAGE="https://qtpass.org https://github.com/IJHack/qtpass"
@@ -16,19 +16,23 @@ KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="|| ( app-admin/pass app-admin/gopass )
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- net-misc/x11-ssh-askpass"
+RDEPEND="
+ || (
+ app-admin/pass
+ app-admin/gopass
+ )
+ dev-qt/qtbase:6[gui,network,widgets]
+ net-misc/x11-ssh-askpass
+"
DEPEND="${RDEPEND}
- dev-qt/qtsvg:5
- test? ( dev-qt/qttest:5 )"
-BDEPEND="dev-qt/linguist-tools:5"
+ dev-qt/qtsvg:6
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
DOCS=( {CHANGELOG,CONTRIBUTING,FAQ,README}.md )
+PATCHES=( "${FILESDIR}"/${P}-qt-6.8-buildfix.patch )
+
src_prepare() {
default
@@ -39,11 +43,12 @@ src_prepare() {
}
src_configure() {
- eqmake5 PREFIX="${EPREFIX}"/usr
+ eqmake6 PREFIX="${EPREFIX}"/usr
}
src_test() {
- virtx default
+ local -x QT_QPA_PLATFORM=offscreen
+ default
}
src_install() {