summaryrefslogtreecommitdiff
path: root/app-admin/pydf/pydf-12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/pydf/pydf-12-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/pydf/pydf-12-r1.ebuild')
-rw-r--r--app-admin/pydf/pydf-12-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/pydf/pydf-12-r1.ebuild b/app-admin/pydf/pydf-12-r1.ebuild
new file mode 100644
index 000000000000..363b2db7d70f
--- /dev/null
+++ b/app-admin/pydf/pydf-12-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="Enhanced df with colors"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/"
+SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/${PN}_${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86 ~arm64 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+src_prepare() {
+ default
+ sed -i -e "s:/etc/pydfrc:${EPREFIX}/etc/pydfrc:" "${PN}" || die
+}
+
+src_install() {
+ python_foreach_impl python_doscript "${PN}"
+ insinto /etc
+ doins "${PN}rc"
+ doman "${PN}.1"
+ einstalldocs
+}