summaryrefslogtreecommitdiff
path: root/app-admin/pwman3/pwman3-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /app-admin/pwman3/pwman3-0.10.0.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'app-admin/pwman3/pwman3-0.10.0.ebuild')
-rw-r--r--app-admin/pwman3/pwman3-0.10.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/pwman3/pwman3-0.10.0.ebuild b/app-admin/pwman3/pwman3-0.10.0.ebuild
new file mode 100644
index 000000000000..c63d60465f40
--- /dev/null
+++ b/app-admin/pwman3/pwman3-0.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+PYTHON_REQ_USE="sqlite?"
+inherit distutils-r1
+
+DESCRIPTION="A lightweight password-manager with multiple database backends"
+HOMEPAGE="https://pwman3.github.io"
+SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mongodb mysql postgres +sqlite test"
+
+CDEPEND="
+ >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.0[${PYTHON_USEDEP}]
+ "
+
+DEPEND="
+ ${CDEPEND}
+ test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
+ "
+
+RDEPEND="
+ ${CDEPEND}
+ mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/pymysql[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ esetup.py test
+}