summaryrefslogtreecommitdiff
path: root/app-admin/pwgen/pwgen-2.07.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/pwgen/pwgen-2.07.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/pwgen/pwgen-2.07.ebuild')
-rw-r--r--app-admin/pwgen/pwgen-2.07.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/pwgen/pwgen-2.07.ebuild b/app-admin/pwgen/pwgen-2.07.ebuild
new file mode 100644
index 000000000000..9df81de14409
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.07.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Password Generator"
+HOMEPAGE="https://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="livecd"
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.06-special-char.patch
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/etc/pwgen
+}
+
+src_install() {
+ default
+ use livecd && newinitd "${FILESDIR}"/pwgen.rc pwgen
+}