summaryrefslogtreecommitdiff
path: root/app-admin/puppet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
commitf660c6de84558324d784218831d8f0782ee41e2e (patch)
treec1f2aa79617d0ceaaff49d71603abc386aae2c37 /app-admin/puppet
parent95461df035e3867364495f065e5e805bf629b2d7 (diff)
gentoo resync : 27.10.2021
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-5.5.22-r2.ebuild141
2 files changed, 142 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index aee59078bfbd..177d46193623 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -7,6 +7,7 @@ DIST puppet-5.5.22.tar.gz 2998132 BLAKE2B 8662c89190d0904fe44ffeca1cf9a9ddca40d5
DIST puppet-7.11.0.tar.gz 2860556 BLAKE2B 4db6e9ba7da3c3fa8af845a9afa4a1029ae9f6e33b1a3977ab06058bdd1c230ec2cb7a7bbe54bfd6a193093f3020136f9dcfcb035f5031c06885d1df51b0f467 SHA512 dca5359c4caa07296c1ae79840d56b96b506521a9b7f32ff5aa4fbecb6277b579dff2f4d0df0c939d5f466f55b56ac8c7e2bd0ad83c024bf403f2652ecac3988
DIST puppet-7.12.0.tar.gz 2862376 BLAKE2B da0d3d05de8187492cbb14d98df0c7eef7fea5a2fdad0f41b687fcef20979d34c1d84513c4c7a504eb95934228b832e416aecb5f626fba20920df286fd403bcd SHA512 5df5b78d5e27ff64e49f440c6e3add7af1b58cd4da6ac5cd649dce012e830e349c2dbc27bf03d4668e2a10cec6628b2872457c7b6f7fe7a4f7cfbd6c8fe8ae2d
EBUILD puppet-5.5.22-r1.ebuild 3751 BLAKE2B f651b0c7d9196a83b00533a2cf6cb3b28e8b5de366cd792ed7194e84b93d971042c3e17a50abefe56e18f67bb0cd3d694604f19dc02c3ed7d72e11f1e0b71d22 SHA512 5d50d74214db6abac3fa66a5249b8b5dbfbc6340c6815e99611e2c62ff6347f2e9c96c53ad79221865e78eeed3e2796941cc50b5a979bdc8a589f57e6681ce06
+EBUILD puppet-5.5.22-r2.ebuild 3761 BLAKE2B 87459e92044c50d12f76b9e1661da595350e6cef7615f747a621d37f82d7c243ce0a4c247c045e06624a0f2472253560fee05d708d87dc8010db930263e71fcb SHA512 b440243d998d8c4a638dbe9b66b6b331686db0d9f655825f5220afc18a80a5f85a84945f2238a9f3c53337b986d89e5fb859df369fce307dc2fcf6b3541bbb66
EBUILD puppet-7.11.0.ebuild 3538 BLAKE2B b210c2f1d770288548d3b401afd9e54f5029e114619c124f4462ea27b0ff9d4e02f01a32b98d35950c330804b54db3e05aabf9e12eee8be0ef2bd9c885bb3706 SHA512 bb903b943b965137b8948ea2ce0716a402c593e152d23a2ddbc9c5b8f786252f4814b33ef6e39eca966e13319823b4adf3ed30b134ca7b78912c760b110f578c
EBUILD puppet-7.12.0.ebuild 3540 BLAKE2B a18427a2c3565af9faf11865b3a7f2aff763ecfd30bc92ab7ef92bf750eb6df69a5168564a617b5abcfab123a82a6741da3337c1a12a76a45bba2c7a4a7b252e SHA512 b30d8ef04c45e6c89b505524bc8b7414b212cfbb281fd53ed212e08ac64c85351bdde0924d50513ef99f24504265a47500c759fd08971947124c4c3484c28bcd
MISC metadata.xml 1570 BLAKE2B 5ea0d1f9d7e83fc99130bc7375de7638fd509d18ea5728d14d370338089c33c788156f20b976e6b909502e94e356428e4a1ce95e10bf307d81bd2fbbb1166941 SHA512 4ec568674227749e9644c4eb09d39c25f2458a7eb89f7d36d2be035845e8ffefc6bffbdbc09be9950bb424f2c940ff9bf43ea60e22cd4816bf12d3593e41e7b1
diff --git a/app-admin/puppet/puppet-5.5.22-r2.ebuild b/app-admin/puppet/puppet-5.5.22-r2.ebuild
new file mode 100644
index 000000000000..fcce80749632
--- /dev/null
+++ b/app-admin/puppet/puppet-5.5.22-r2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit ruby-fakegem systemd tmpfiles
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="https://puppet.com/"
+SRC_URI="https://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/hiera-3.2.1:0
+ =dev-ruby/facter-3*
+ >=dev-ruby/fast_gettext-1.1.2:0
+ >=dev-ruby/locale-2.1:0
+ >=dev-ruby/multi_json-1.10:0
+ dev-ruby/sync
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0
+ acct-user/puppet
+ acct-group/puppet"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # fix systemd path
+ eapply -p0 "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+ newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet.conf
+
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+
+ for v in ${REPLACING_VERSIONS}; do
+ if [ "$(ver_cut 1 "$v")" -eq "4" ]; then
+ elog
+ elog "Please see the following url for the release notes for puppet-5"
+ elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
+ elog
+ fi
+ done
+}