summaryrefslogtreecommitdiff
path: root/app-admin/puppet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /app-admin/puppet
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest2
-rw-r--r--app-admin/puppet/puppet-7.9.0.ebuild132
2 files changed, 134 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index a2c4756ee3d6..363b6946dff7 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -5,6 +5,8 @@ AUX puppetmaster.init-4.x 1108 BLAKE2B 1793d3d881de2c1808159f940bf1e758c2e7fad8f
AUX tmpfiles.d 39 BLAKE2B 2c9a992bf709a384ae02395299ddeb2febf3cd83b924acd97d0ca7fbc17dac273cb27c926790708c0d929f62282dec0477f167ed2e5fc1418a9ff5d130f246f1 SHA512 2dfec45e6f762ce0431d55b1a826e707e970defacbe050df838b66b347e7423eac78a35248c74908e7b52fa84cde5129ce3f562f64dac357f0368a3bc0b719a1
DIST puppet-5.5.22.tar.gz 2998132 BLAKE2B 8662c89190d0904fe44ffeca1cf9a9ddca40d57ba6fb2d1e644ca353ceb55b1ca3a91416f1eef2975233c9c4498784e7d7280c111ea0cc070870cadc69341d99 SHA512 5332b084a63bdf244672cc4751022c84a1cc50d3f394a13bdcbccf7fcf4ebea67953e88957f23046608bf25e9182548449be824c18289cb2bf1e3ed29b40dc58
DIST puppet-7.8.0.tar.gz 2893281 BLAKE2B cef1d56048a72ffa18c9fe2917e4f616dd4d778eddc91c88becf06a418471af1e2cf1688aa05ad3e71f24d5bb1923eaf35b8a1419ed05a72b299af970d1427e6 SHA512 189fabe199afefc77951ee3f2bf20c749f6efe290cc3a76f5ba58892c80cc76082b1ce77c23bca87f57f62816410bc5536e4206806fe31517915c72046ace08d
+DIST puppet-7.9.0.tar.gz 2899891 BLAKE2B 06f675fc9eaac4ddfa7957847abe33928f0779f3c18dbf339067525ec69b6b87d274294a1133ec8332fbbed6111b568c63478493f3de467c63e2948bcf446b71 SHA512 6329d89530d2cb008e28116de655024e9bf944b3f41d086e0e47c41c74af3da51c283a912ac966cf7bac52f86e54304df6cf31477a5663cae09fb4d18f958cf2
EBUILD puppet-5.5.22.ebuild 3751 BLAKE2B bde3bbacdd70435fe0e804133106ebc887f72da5742c871bfdaed08a084866f178b68433453d392f7e98f8f5a2297ee10e7b6e035392fecd22a84780a2b431b2 SHA512 5bc024d0696e51de520ca6ba162cf312ddc9cca04ba5ee18f849ca48547f31e4a493664ffd0100022ef4fb69ad1c24b1efccf7a25d85652281da71c446b87f26
EBUILD puppet-7.8.0.ebuild 3538 BLAKE2B a5419de57c88bcab6796a2df14afca910f1b466a0ca20fc40b3b937053059d126a4ef845ca9ad2903f2c4afe6b86f19fbfd61779e54a0e3b2a51622ac9dfe07b SHA512 70be4cbede4a005ab5d01daf6ad49e3349c818c56abbe62d9021ec748b8d1b431821baed282c813d53b488d803ef715253300a12bd0cc79216c927d2bb4ba7b8
+EBUILD puppet-7.9.0.ebuild 3540 BLAKE2B 1239d0f1d9a6cdb8dab7965c51c8c7879e20cf2089dd67a1c8903bf8da1aa03c53af3485f82621f1656ef71866c7df92777b66447858319e79c865174c42c458 SHA512 f13b7f037fa7b5f25d37752a6c5f4cdebec9e1ca4f272a1ab4023d3cf79f47c98c4b5df49e996565205e8e9e80296ecbebf5b9ca4ae98b1371b657662ed179da
MISC metadata.xml 1569 BLAKE2B 689531701af0604e7a10f59f2eb721c133796a6c7a87d6a9bffef26ed71d7135b9498450274f4875feb5c45ad7b1aa8458be9a71145f1c0f089b9db687be3cba SHA512 a5672e5d6191264e037e60dd3d2d2d545719fe0edc5db1372b6f1c83a05ebf8b4c5b171b5a80f5ec55a531cec3e37d8b9207adcbf38925efe193eecd80999198
diff --git a/app-admin/puppet/puppet-7.9.0.ebuild b/app-admin/puppet/puppet-7.9.0.ebuild
new file mode 100644
index 000000000000..125aa53e82ce
--- /dev/null
+++ b/app-admin/puppet/puppet-7.9.0.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ dev-ruby/concurrent-ruby
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0
+ acct-user/puppet
+ acct-group/puppet"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # fix systemd path
+ eapply -p0 "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"
+ dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+ elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
+ elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
+ elog "not already done so."
+ elog
+}