summaryrefslogtreecommitdiff
path: root/app-admin/puppet-agent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-admin/puppet-agent
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.13.1.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index decc51946ce7..64c81e3a54e4 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,4 +1,6 @@
AUX puppet.initd2 758 BLAKE2B caf8c2e3563f24d9d313e790498dc362fcd14467ca2b6329cf454a5163bae5cfa2b7af1a212b2e5bfcb4693c7291d5306e47e574d3c937aaedd02625dc954a9e SHA512 df93f7dbcf61eee9f42f4a0c2fa0e2dfc806ac737ba98329cee158e04150c9bf346abd9364b2a6824df4bb862e676be7b2c23f5947ef5aa589df745ac5c5cd03
DIST puppet-agent_7.12.0-1focal_amd64.deb 20971412 BLAKE2B afb9af877e578b6ae24566e0688d14fa67fdb133a3fd9e15dc2473ea76f61a6551bd69a6fad18b6b555eea2afa8fd858a005f2c1cf6681c28f4422129211dea9 SHA512 f5fdab728baa7813f31ba174b0ee7e9dee3f5f954ed46a2f6740cf6ad075c8f36a1b6cb28e7c6223eb4aad02400252114a5dcede0085f7a7e7ba079bad2aedf9
+DIST puppet-agent_7.13.1-1focal_amd64.deb 20985856 BLAKE2B b5e3a2ac94af1f45f0ea5131cff74be1ded6efd9d0951624cec49fa00bc98fb4711e1593be46871c96cac130a636e3d217d6e7515082ca5c409858d982f25a78 SHA512 b5a8ebd99028b859a5100b8cc64684c2fa8257b27259f0ee1c87ddfcbfd9d3c2af48bafbdad524ffeeff743d8da6e46979a84555942ca9b9e4d93a12c08bc552
EBUILD puppet-agent-7.12.0.ebuild 2475 BLAKE2B fe0abbb691d683c9edbd966eb3676c2b0c0a05535f179af030a1392030aef2a0ae9da5aa1948f79390b364c64befc90cf785cf656f504e315a5d86ddac278f21 SHA512 49117ad9d47ea1d293db51c7cf4fecc68700aed007df48a76b3585fd195fadca8d0e3a6341c8fa586bbab35359b1ccffde4020eb734d8f06644105eb6dfa4b2b
+EBUILD puppet-agent-7.13.1.ebuild 2476 BLAKE2B 61b7d8647f55e8324a77cf28394e4ff755017d66da20ff782303c829dfba9d0831bd5b17dd3a498acf1578053bce7d5e5b4f070a5e5b30887fc555258627fa17 SHA512 c99ee3447e1b5e93ae41551b99b9aef4c16c911a8a6f8a25847e45c5135550405ca6e3f0dd5c39f954e786b567e14ed5619b0c2db25cdcd09f41dc8d87149196
MISC metadata.xml 1032 BLAKE2B 35156eb59a786ad7dab4ac5c281796af6a8f3dcad2b7ebc2c6af926aee6fcbffaef39f0f7119f1aefed42a1e8148f323ee4d3d5f77dfb4d3671317af6fd078cc SHA512 b624438f825e288802e516637dd38f775a63b4a4aabaa53c5adfd1f71f694018dbf3d47f1622a90d5da25a00aac696f9203c085190e574a586f3a3e4fe14f9d1
diff --git a/app-admin/puppet-agent/puppet-agent-7.13.1.ebuild b/app-admin/puppet-agent/puppet-agent-7.13.1.ebuild
new file mode 100644
index 000000000000..6e7e8d74150a
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-7.13.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+# virtual/libcrypt:= is in here despite being a pre-built package
+# to ensure that the has_version logic for the symlink doesn't become stale
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet
+ virtual/libcrypt:="
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+
+ # Handling of the path to the crypt library during the ongoing migration
+ # from glibc[crypt] to libxcrypt
+ # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
+ if has_version "sys-libs/glibc[crypt]"; then
+ local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
+ else
+ local crypt_target='../../../../usr/lib/libcrypt.so.1'
+ fi
+ dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}