summaryrefslogtreecommitdiff
path: root/app-admin/psmon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/psmon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/psmon')
-rw-r--r--app-admin/psmon/Manifest3
-rw-r--r--app-admin/psmon/metadata.xml10
-rw-r--r--app-admin/psmon/psmon-1.39-r1.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/psmon/Manifest b/app-admin/psmon/Manifest
new file mode 100644
index 000000000000..7631cc7649ab
--- /dev/null
+++ b/app-admin/psmon/Manifest
@@ -0,0 +1,3 @@
+DIST psmon-1.39.tar.gz 57475 BLAKE2B 37998dabcfe5b329f74b7f6996fe3e8a350cc756a064e98549a38ade997115c3f03c57bf8b145c732edb021fe615be2a1210419f8b77666ad5caa79b74ccdc75 SHA512 08992023af29433da0fe8c48b610df3008b9ea14e197b52bc9582895275fc65cd0faca7e29f36356344219d6a61ef9350713aaa60377ce7ae49a882044b91e32
+EBUILD psmon-1.39-r1.ebuild 695 BLAKE2B 0dd013438894ea6a1fd4aa6851c59c611dffe6aef97aba66c36ebefd45a1ac13898d05e0f0755d975af79a3a3ed98e669b44f75c088edf5f91c79b04ff0a0bea SHA512 54a8b473acd59f2f75851ff5e67d6113632f9d11f5f61cc0d1939d6e800a14ec1781e34dbb287c938cee00057161d9f44f99d009e598d5d664bb044778f98cc0
+MISC metadata.xml 375 BLAKE2B 74e5f745053591b49f00e4040f0e06afd9133c3d26fdff1047e591f06babb50e1af8616c7416de01793ff8294986b56937ae9c3fa244e7493f0a3e926ccd34ba SHA512 450413515ed27e78edeec89a59c27cb83efb6c5be58cf5321d1212ca191c5d87c6982e7d8cfb8f28a79383c529ecbaa7b02219d695dc5712b5566afada6fcf08
diff --git a/app-admin/psmon/metadata.xml b/app-admin/psmon/metadata.xml
new file mode 100644
index 000000000000..fb1a2d3c2106
--- /dev/null
+++ b/app-admin/psmon/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ A perl script that monitors processes to make sure they are running as
+ the user has intended. Will respawn dead processes and/or kill illegal
+ processes.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/psmon/psmon-1.39-r1.ebuild b/app-admin/psmon/psmon-1.39-r1.ebuild
new file mode 100644
index 000000000000..c1f5927344ec
--- /dev/null
+++ b/app-admin/psmon/psmon-1.39-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit perl-app
+
+DESCRIPTION="Monitors process table to slay aggressive, and spawn dead, processes"
+HOMEPAGE="http://www.psmon.com/"
+SRC_URI="http://www.psmon.com/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/Config-General
+ dev-perl/Proc-ProcessTable
+ dev-perl/Unix-Syslog
+ virtual/perl-Getopt-Long"
+
+src_install() {
+ perl-module_src_install
+ insinto /etc
+ doins etc/psmon.conf
+}
+
+pkg_postinst() {
+ einfo "NOTICE: Please modify at least the NotifyEmail parameter found in"
+ einfo "the /etc/psmon.conf file"
+}