summaryrefslogtreecommitdiff
path: root/app-admin/ps_mem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /app-admin/ps_mem
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'app-admin/ps_mem')
-rw-r--r--app-admin/ps_mem/Manifest4
-rw-r--r--app-admin/ps_mem/metadata.xml8
-rw-r--r--app-admin/ps_mem/ps_mem-3.12-r1.ebuild28
-rw-r--r--app-admin/ps_mem/ps_mem-3.12.ebuild29
4 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/ps_mem/Manifest b/app-admin/ps_mem/Manifest
new file mode 100644
index 000000000000..b878da859c8e
--- /dev/null
+++ b/app-admin/ps_mem/Manifest
@@ -0,0 +1,4 @@
+DIST ps_mem-3.12.tar.gz 18074 BLAKE2B 98861120b09b3a25b29b5b461d50d8e6a8a684fe76685a7b032f769896dba4b8fa6cd1b1de2644488bf8b4568b960f2949eac2a72a6225cd19682a9c08803baa SHA512 aeba7573b651ffbe6bb263ecc257716cc91219aac232694a628b0e5b1e45235149d7dcf68f6b9ee669bd005adf68693cd09f32e378934690270b0b72c38abea4
+EBUILD ps_mem-3.12-r1.ebuild 665 BLAKE2B b63af8599f99ab56b3cfdb89e97d49bb12369ba4fd5178df3ba89ab7060748333c13da80c7657833fec7808aa2e8d78aeffc60ea81d3bf98a706437bd2f4354a SHA512 1b404e315f03428488a01489dec513e20bc5458eee9b05ac07716ff2137bf0292ee473a8af51af263bbdebfea5a9933361e1d601849154bcfda159c2b568718e
+EBUILD ps_mem-3.12.ebuild 658 BLAKE2B b21e5495cc82e6b2ff1033c3013e94a08b05e662dd0e9942a07ab4987b73655e4f68d375e873986f0376fce51a001cc8e1388775a6188ab4667be888e6096dd3 SHA512 8b7f19f11032a6152fcdd57fca9b1a46c4fa320364a2cfacbc9c3e08068cb7a1995ecc720c1e4e3863c464ec093a6385fdb7f93117e2b93a00ba0fbcef9be14f
+MISC metadata.xml 240 BLAKE2B 5caea4abbcf161615353b1f5ec499ae37ae67f08f6f1d48829d145694359169508d62173c091700e9a65d8ed461216caf12cc6728760784aa364d610250369ca SHA512 ee5c2cad860daff025c5d2bbc7e210767432dd09d1a74fc7b1d5994686d48739b9bfd446bf1ab7b1b92532f82767e722ea3e38d7a502a7a941f6ac5028000ce8
diff --git a/app-admin/ps_mem/metadata.xml b/app-admin/ps_mem/metadata.xml
new file mode 100644
index 000000000000..435234188908
--- /dev/null
+++ b/app-admin/ps_mem/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-admin/ps_mem/ps_mem-3.12-r1.ebuild b/app-admin/ps_mem/ps_mem-3.12-r1.ebuild
new file mode 100644
index 000000000000..82174961a3b7
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.12-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/${PN}"
+SRC_URI="https://github.com/pixelb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}
diff --git a/app-admin/ps_mem/ps_mem-3.12.ebuild b/app-admin/ps_mem/ps_mem-3.12.ebuild
new file mode 100644
index 000000000000..a60e22bad8fc
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/${PN}"
+SRC_URI="https://github.com/pixelb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${PYTHON_DEPS}"
+
+python_install() {
+ distutils-r1_python_install --install-scripts="/usr/sbin"
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman ${PN}.1
+}