summaryrefslogtreecommitdiff
path: root/app-admin/ps_mem/ps_mem-3.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /app-admin/ps_mem/ps_mem-3.13.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'app-admin/ps_mem/ps_mem-3.13.ebuild')
-rw-r--r--app-admin/ps_mem/ps_mem-3.13.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/ps_mem/ps_mem-3.13.ebuild b/app-admin/ps_mem/ps_mem-3.13.ebuild
new file mode 100644
index 000000000000..cedefddc1a27
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 vcs-snapshot
+
+COMMIT="9f54e1aa3a87ec176ce8b71f02673e0d8293b344"
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/${PN}"
+SRC_URI="https://github.com/pixelb/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}