summaryrefslogtreecommitdiff
path: root/app-admin/procinfo-ng/procinfo-ng-2.0.304-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
commite80777b54c5b430ca044e16878f59a2020423d48 (patch)
treeb72b3422d129532b8f0ceb415c6e7c5109e3fe75 /app-admin/procinfo-ng/procinfo-ng-2.0.304-r2.ebuild
parentaa61828f226f3b30e6939408847d914a145fdf35 (diff)
gentoo auto-resync : 10:11:2022 - 09:27:33
Diffstat (limited to 'app-admin/procinfo-ng/procinfo-ng-2.0.304-r2.ebuild')
-rw-r--r--app-admin/procinfo-ng/procinfo-ng-2.0.304-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/procinfo-ng/procinfo-ng-2.0.304-r2.ebuild b/app-admin/procinfo-ng/procinfo-ng-2.0.304-r2.ebuild
new file mode 100644
index 000000000000..d9384bee0dd8
--- /dev/null
+++ b/app-admin/procinfo-ng/procinfo-ng-2.0.304-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Completely rewrite of the old system monitoring app procinfo"
+HOMEPAGE="https://sourceforge.net/projects/procinfo-ng/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-man.patch
+ "${FILESDIR}"/${P}-wformat-security.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ # bug #719790
+ append-cxxflags -std=c++03
+
+ default
+}