summaryrefslogtreecommitdiff
path: root/app-admin/pprocm/pprocm-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/pprocm/pprocm-1.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/pprocm/pprocm-1.0-r2.ebuild')
-rw-r--r--app-admin/pprocm/pprocm-1.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/pprocm/pprocm-1.0-r2.ebuild b/app-admin/pprocm/pprocm-1.0-r2.ebuild
new file mode 100644
index 000000000000..a91f192678ca
--- /dev/null
+++ b/app-admin/pprocm/pprocm-1.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="PProcM"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ncurses-based program to monitor CPU, disk, network and memory usage"
+HOMEPAGE="http://www.fusedcreations.com/PProcM/"
+SRC_URI="http://www.fusedcreations.com/PProcM/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ dev-perl/POE
+ dev-perl/Sys-Statistics-Linux
+ dev-perl/IO-Pipely
+ dev-lang/perl"
+
+RDEPEND="
+ ${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README )
+
+src_install() {
+ newbin "${MY_PN}" "${PN}"
+ einstalldocs
+}