summaryrefslogtreecommitdiff
path: root/app-admin/pass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /app-admin/pass
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'app-admin/pass')
-rw-r--r--app-admin/pass/Manifest2
-rw-r--r--app-admin/pass/pass-9999.ebuild27
2 files changed, 19 insertions, 10 deletions
diff --git a/app-admin/pass/Manifest b/app-admin/pass/Manifest
index 47bc89667c0c..090fb1f35702 100644
--- a/app-admin/pass/Manifest
+++ b/app-admin/pass/Manifest
@@ -1,5 +1,5 @@
AUX 50pass-gentoo.el 491 BLAKE2B 30c24a820e877e74d4308b42fab036c3c670353af6eb79454c18b471ab62134074765c313be5633e5fc8d1d9105a51d4dc648e3e08f200487ea62e3b9cd4e4a1 SHA512 eaba952f7b080bb44f1a415ee3fa1e71469177a993116b890a0788b177ec70948c1ea6923f17ddddf5f1c01af2fca03e98a71e06a5dff32ff6ebe0b73a79f659
DIST password-store-1.7.3.tar.xz 63416 BLAKE2B 5931608e0208dfe6965b79f586c153a4930d1c3d3b74433d026ee0bc5889fcc29334c637ca4fb68308d0169bad7c8235b6632e9f80eda1e24f0f5721353f88e3 SHA512 89755a7b02f05d75055a9fc14fd3f456c0a49ec31bdffd097a027f91228c64a98b18c1e80017aeda811773ae3287ff1b9737532da8ded06799d8fe3979ca06f7
EBUILD pass-1.7.3.ebuild 2189 BLAKE2B 8ee842903bfe1c01a62f423eac78cc96f59129c714406f3af605ddb0d3043b481a3748a19dccb5b2cb31da0416cc65d5bcf0627dbfaffcfd46f71f0efc66a58c SHA512 ce590f22fcfb55abc462cb5351f658867d4e3a182ae8ccf7e0d5a183c49514a3f1d1bc3ce9aa41f0a8e8585ff750b21a666d6c14797ff42a8269d5bf6104f77d
-EBUILD pass-9999.ebuild 1970 BLAKE2B f2b42a0e2373581160439a6d1e89af0b873aa4140035d6f918572fafc1b9b8b8d7b31722edc61a8e771bf6912f73f5d8f358bc660c15bbdb12d23d4569d5c4dd SHA512 532a628a7d0192763af3237106e737af3a2d26fe3db2f68134569df2450cef59f1f789301020fb0930ff6c0e2e10fca8161f2b29bb288ad2af0f5f18e7ca3a96
+EBUILD pass-9999.ebuild 2300 BLAKE2B 9d002c0e8807479e45ad2c945f9c5c3976cb6ca4cc18e78cfa0c1d0f5c8025643579d56ba4eb6cc33690b92f33bba0cf7a9f0004c24de911bd37cfc423dc2ed4 SHA512 87a0d7170f0e6029fd1f80b0b001ca76598415cd0dbf488f5c2341c72ca49e4b37ec668999224d3976ca1ec8aed7a04487172d05277b0d5330149dbe8cb976b3
MISC metadata.xml 747 BLAKE2B 0fa61ff5f87f66214e11c38fe1dd0dc746b8151bc201c72d972ddbd0f8e32dc89701798746df8e2c912eb0d4ccf43fc91d857dfc5395d184f4da24d5128f7b13 SHA512 5fb903b4d06cd49dea554f2a94bbd79e544840e4cce4e876b12eeaceb45aa6321a3fe50f1d531fdeb9cbd34dab66b2bf3ac0be52b07edaf62acf69a892c96200
diff --git a/app-admin/pass/pass-9999.ebuild b/app-admin/pass/pass-9999.ebuild
index 9f6082612879..41d248d350e1 100644
--- a/app-admin/pass/pass-9999.ebuild
+++ b/app-admin/pass/pass-9999.ebuild
@@ -1,17 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit bash-completion-r1 git-r3 elisp-common
+inherit bash-completion-r1 elisp-common
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://git.zx2c4.com/password-store"
+ inherit git-r3
+else
+ SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S="${WORKDIR}/password-store-${PV}"
+fi
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
-EGIT_REPO_URI="https://git.zx2c4.com/password-store"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS=""
IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
RDEPEND="
@@ -24,10 +31,12 @@ RDEPEND="
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
- emacs? ( >=app-editors/emacs-23.1:* )
+ emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
src_prepare() {
+ default
+
use elibc_Darwin || return
# use coreutils'
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
@@ -38,7 +47,7 @@ src_prepare() {
}
src_compile() {
- :;
+ use emacs && elisp-compile contrib/emacs/*.el
}
src_install() {
@@ -51,7 +60,7 @@ src_install() {
WITH_FISHCOMP=$(usex fish-completion)
use dmenu && dobin contrib/dmenu/passmenu
if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el
+ elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
if use importers; then
@@ -65,7 +74,7 @@ pkg_postinst() {
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
- einfo " ${EROOT%/}/usr/share/${PN}/importers/"
+ einfo " ${EROOT}/usr/share/${PN}/importers/"
fi
}