summaryrefslogtreecommitdiff
path: root/app-admin/pass-otp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-admin/pass-otp
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-admin/pass-otp')
-rw-r--r--app-admin/pass-otp/Manifest1
-rw-r--r--app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/pass-otp/Manifest b/app-admin/pass-otp/Manifest
index ff0e46a83824..f79e6896b332 100644
--- a/app-admin/pass-otp/Manifest
+++ b/app-admin/pass-otp/Manifest
@@ -1,3 +1,4 @@
DIST pass-otp-1.2.0.tar.gz 46789 BLAKE2B 373b1ddfb4cfae07e9e58bdad1c9c73ca6c6f53fc140ccda21527ad2ae237d3402bc52e95a180811263ef1a29f5c9da7db0063178b19a85b1dafc3d20e22996d SHA512 3d1417462998750ef1580169ed0e4b721b5f430cd86a678d1b6bc7b2ac123879902f7d22c28dc21e8a171ec80dfc51b6465d0dcc78cb009eb731651f2cb152f5
+EBUILD pass-otp-1.2.0-r1.ebuild 666 BLAKE2B 495c19880c3dfb090808c814cc2963f97fbe238c5954a73a033071816ecc43fcd7bbb3e5d93b6ee609f850492aaf4dce09ec9ab3eb1d492f2425d25674728ed4 SHA512 7a4f52be423a7c9e33b2c69b4e14881b208446f82f286b8981716af9cfa6a7a1a07c760292417d0829bca7266655480070a57a95645692e132f81a1b994d02ba
EBUILD pass-otp-1.2.0.ebuild 680 BLAKE2B 9733202a8349acc44868ed889684335318f1ff368e2335854d1352e3fccfb721bf01db7edc493b6506c3275e8caeacafce43574aad6722e6e1cfca948e2e734d SHA512 06d190a4fa137b1c6e26a2ca4e8cebac066b5bb5a2069d3ed8fe4522aef238faf3800e9ef178ccb8de0b6d12630fe15f93a380994fdd7a0a0db9c110c666aa18
MISC metadata.xml 615 BLAKE2B 9637571a6615665350ee8e26e79219bba4a25db7d61160a0736901fc17a10f2a1a610d3bd48cd2ddd62bde133701787797ad9921a3187ae448b4949a206311c0 SHA512 819fc51638c67e7ff41875446913f3146bbe9f0dc0d25ee1de250b09ef3fa3ce9b2ef60db079630a9f324060636a5a6bd4b2eaed988b0ecbe2c04bc15daff5bd
diff --git a/app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild b/app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..65f765ec2d8b
--- /dev/null
+++ b/app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="A pass extension for managing one-time-password (OTP) tokens"
+HOMEPAGE="https://github.com/tadfisher/pass-otp"
+SRC_URI="https://github.com/tadfisher/pass-otp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-tcltk/expect:* )"
+
+RDEPEND="
+ >=app-admin/pass-1.7
+ sys-auth/oath-toolkit
+ media-gfx/qrencode
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake install DESTDIR="${D}" BASHCOMPDIR="$(get_bashcompdir)"
+}