summaryrefslogtreecommitdiff
path: root/app-admin/packagekit-qt/packagekit-qt-0.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/packagekit-qt/packagekit-qt-0.9.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/packagekit-qt/packagekit-qt-0.9.6.ebuild')
-rw-r--r--app-admin/packagekit-qt/packagekit-qt-0.9.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/packagekit-qt/packagekit-qt-0.9.6.ebuild b/app-admin/packagekit-qt/packagekit-qt-0.9.6.ebuild
new file mode 100644
index 000000000000..a10b5392407d
--- /dev/null
+++ b/app-admin/packagekit-qt/packagekit-qt-0.9.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_PN="PackageKit-Qt"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Qt PackageKit backend library"
+HOMEPAGE="http://www.packagekit.org/"
+SRC_URI="https://www.freedesktop.org/software/PackageKit/releases/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ >=app-admin/packagekit-base-0.9
+ >=dev-qt/qtcore-5.6:5
+ >=dev-qt/qtdbus-5.6:5
+ >=dev-qt/qtsql-5.6:5
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"