summaryrefslogtreecommitdiff
path: root/app-admin/opentofu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-23 16:46:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-23 16:46:30 +0000
commit1f1ada4b2afd8dd8de6ac1e0f94702abf05654bc (patch)
tree2d9c4727985711ca133f754404d7ef6c40d82be3 /app-admin/opentofu
parent02d5de423c2b7f8d7c873bcc7a1a222b1847149d (diff)
gentoo auto-resync : 23:01:2024 - 16:46:30
Diffstat (limited to 'app-admin/opentofu')
-rw-r--r--app-admin/opentofu/Manifest4
-rw-r--r--app-admin/opentofu/metadata.xml12
-rw-r--r--app-admin/opentofu/opentofu-1.6.0.ebuild40
3 files changed, 56 insertions, 0 deletions
diff --git a/app-admin/opentofu/Manifest b/app-admin/opentofu/Manifest
new file mode 100644
index 000000000000..9c7942544298
--- /dev/null
+++ b/app-admin/opentofu/Manifest
@@ -0,0 +1,4 @@
+DIST opentofu-1.6.0-deps.tar.xz 332007504 BLAKE2B 1c2a7d2350944d34308baa0566977aad914b3c4f989ba90d51cb52e3001d11e56952906b0dab7adc5cef261290b748c0567e35c66f6701d62d750e18d0acea5f SHA512 5c5644b2caef5439e50865569abec133ba57a6e6581d8f8d38500671818079b471afcd86422858475b1ca912bdb75fe0b91227012f5c597bcaabe1a215b2eb09
+DIST opentofu-1.6.0.tar.gz 3696642 BLAKE2B e224ce14f04d07638d03b9a11ab251cd820acc86774f9c82f38f5bcfc38b62bbdbc70377e722a4dd2bd65f917ba0fc200ccaaeafdbd9430af66586491c7627eb SHA512 758f4ff79e526e9494e1e98dd927dbeb803b45df1f8bc15c3a9bca8343d7285b9130bfe5f19f6ddd7fd403b72d852b0d51542c058174e4bd5eed3c729b394bdb
+EBUILD opentofu-1.6.0.ebuild 844 BLAKE2B bdfa0b0c680d11a0dc80829f2acfbbd919efd06d6f5a2fc1478455a15e1aa8d1fbf633a23f9479677449a1561a2bc56c85766f94d0561a5df211116c1a395e50 SHA512 54b6886c941cb45f8965816bc2ecd161d2efa79348adf42b3f12bc1217d13f7de47a1a09deff7836864ccf76a7ef198320e7fbe506ed7c4489c494fc20026cc9
+MISC metadata.xml 417 BLAKE2B 82486cb8f3504862ce7658f0d54141e559a952874ec92697e7bd03f7f7a1e4a3df90a20158c8be6b4bb42d9c4e9de49c27754589e909a4e32ec52950a3d169bd SHA512 2a347bf9bd1be70d9e1853ae802091fcbea299a15fe4c170aacba005e7528c3b9c784d2b34bfff015f1b531648e6fb2e73ff3fb9d158df0991b3348a91f74eb6
diff --git a/app-admin/opentofu/metadata.xml b/app-admin/opentofu/metadata.xml
new file mode 100644
index 000000000000..cbe6b0ede320
--- /dev/null
+++ b/app-admin/opentofu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/opentofu/opentofu/blob/main/CHANGELOG.md</changelog>
+ <remote-id type="github">opentofu/opentofu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/opentofu/opentofu-1.6.0.ebuild b/app-admin/opentofu/opentofu-1.6.0.ebuild
new file mode 100644
index 000000000000..544c2e0b5f16
--- /dev/null
+++ b/app-admin/opentofu/opentofu-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="The open source infrastructure as code tool"
+HOMEPAGE="https://www.opentofu.org/"
+SRC_URI="https://github.com/opentofu/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MPL-2.0 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-go/gox"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ export CGO_ENABLED=0
+ gox \
+ -os=$(go env GOOS) \
+ -arch=$(go env GOARCH) \
+ -output bin/tofu \
+ -verbose \
+ ./cmd/tofu || die
+}
+
+src_install() {
+ dobin bin/*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " tofu -install-autocomplete"
+}