summaryrefslogtreecommitdiff
path: root/app-admin/op-cli-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
commit2e34d110f164bf74d55fced27fe0000201b3eec5 (patch)
treef00ae60197c58f84ad51f60b210738d9b70f555b /app-admin/op-cli-bin
parentf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (diff)
gentoo resync : 01.10.2020
Diffstat (limited to 'app-admin/op-cli-bin')
-rw-r--r--app-admin/op-cli-bin/Manifest3
-rw-r--r--app-admin/op-cli-bin/metadata.xml8
-rw-r--r--app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild23
3 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/op-cli-bin/Manifest b/app-admin/op-cli-bin/Manifest
new file mode 100644
index 000000000000..454463de4985
--- /dev/null
+++ b/app-admin/op-cli-bin/Manifest
@@ -0,0 +1,3 @@
+DIST op_linux_amd64_v1.7.0.zip 3989846 BLAKE2B 074bcc248438c1cfa0436726fb3b101e5d60c477c406434d00bb7689d6004796373d8562e22fa870239c9d2234cfae21d7a8aa2b90e7807cb15df8870b2afd64 SHA512 7ab0792ba737a8f95ec874dc111fdb6cd45d552c5b5cfb9d35423a76f444c15718269e77faae978d773bfcaa7e7607f4b8b7e93616c8f7fc91caafb35c856a5e
+EBUILD op-cli-bin-1.7.0.ebuild 518 BLAKE2B 9c4029bf113eedc6494abc6f5698f92a882458f77a5c69185866446284c3f870d4276f538b08ef0372376a6cafc602c35a1c94a7ce209579659901e40db0f41c SHA512 8034aca87e94910664e04e1ffda780363f01c766bfbee4bb67c7ed30a48af804ec72f2633942a97265c2461bf458de7f1031e7768e6417cf413c31056657456b
+MISC metadata.xml 248 BLAKE2B 5d9c3678c604aac0f24c5d5015e28f02b9ce83bb6a179755a44adeb3d69e4dd50be4acc30a6317649f5be23bcf13ac210bbe4712aa403e9c4cf2de351b39c941 SHA512 dc5b06a888be6367909895d5891a08189f4657bcee602e5ff0021be2ad3677e58ec7387ff244625be66a142138666e7eac790d2a7b1e298f0ad644725b5e57e0
diff --git a/app-admin/op-cli-bin/metadata.xml b/app-admin/op-cli-bin/metadata.xml
new file mode 100644
index 000000000000..c36c37139fad
--- /dev/null
+++ b/app-admin/op-cli-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild b/app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild
new file mode 100644
index 000000000000..a1bbc9ae0b9c
--- /dev/null
+++ b/app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command line interface for the 1password password manager"
+HOMEPAGE="https://1password.com/downloads/command-line"
+SITE="https://cache.agilebits.com/dist/1P/op/pkg/v${PV}/"
+SRC_URI="${SITE}/op_linux_amd64_v${PV}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-arch/unzip"
+
+QA_PREBUILT="usr/bin/op"
+RESTRICT="bindist mirror"
+S="${WORKDIR}"
+
+src_install() {
+ dobin op
+}