summaryrefslogtreecommitdiff
path: root/app-admin/mkosi/mkosi-14_p20230313.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
commitc55c2cf7b5e5e8ce7f21c53ee7996c2ea918279d (patch)
treee8bb447a647aa737a0da2ede957972eb72e7dcd4 /app-admin/mkosi/mkosi-14_p20230313.ebuild
parentd41bd0acd3d0cd850cdd815b12e69ee2c89c5697 (diff)
gentoo auto-resync : 28:03:2023 - 21:51:31
Diffstat (limited to 'app-admin/mkosi/mkosi-14_p20230313.ebuild')
-rw-r--r--app-admin/mkosi/mkosi-14_p20230313.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/mkosi/mkosi-14_p20230313.ebuild b/app-admin/mkosi/mkosi-14_p20230313.ebuild
new file mode 100644
index 000000000000..815dd1509bbe
--- /dev/null
+++ b/app-admin/mkosi/mkosi-14_p20230313.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+COMMIT='33a33967819443ee03137459eec85cd5db6c4bad'
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Build Bespoke OS Images"
+HOMEPAGE="https://github.com/systemd/mkosi"
+SRC_URI="https://github.com/systemd/mkosi/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="
+ app-emulation/qemu
+ dev-vcs/git
+ sys-apps/bubblewrap
+ sys-apps/portage
+ sys-apps/systemd
+ sys-firmware/edk2-ovmf"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "For debian support: " dev-util/debootstrap
+}