summaryrefslogtreecommitdiff
path: root/app-admin/mcelog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-admin/mcelog
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-admin/mcelog')
-rw-r--r--app-admin/mcelog/Manifest3
-rw-r--r--app-admin/mcelog/mcelog-180-r1.ebuild51
-rw-r--r--app-admin/mcelog/mcelog-180.ebuild47
3 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/mcelog/Manifest b/app-admin/mcelog/Manifest
index 65bb02efe7d3..387636ef4ab8 100644
--- a/app-admin/mcelog/Manifest
+++ b/app-admin/mcelog/Manifest
@@ -3,5 +3,8 @@ AUX mcelog-129-debugflags.patch 416 BLAKE2B 97aa6da3146380b40013966bb109de412158
AUX mcelog-179-fix-logrotate.patch 486 BLAKE2B 9eebf0b3f374b052637457c4e85a91f67efdf2debe260aa412f97a8cc84bd000f6ce25499dbc14ea9e11d7210a1424ae1295e572bbdc07dfa2be245825b4ea0e SHA512 af4d76c1f52cca40a766c5cad8a93ddaaa942336acf6e7a20a638d0982ed1444cca52e332d1a72a9ae2b8d538039e911cd2226f3ee143f0f867db77fd5fdc82f
AUX mcelog.init-r1 349 BLAKE2B 17f8a28dc1174fa62d50cb0d6dcae7bf4755ea99ff380d42a5beb16ab6ca07f1dbfcf7783ecb3b8f85f714357c39b0a333630c69e0bef5af32ba602686117cfd SHA512 a43f0efe7eb5007e9422ca2eba43b666d5110696c8b049b74990849e200b89b99e3d22707803e21e4452b0e75bbacdec0526ed933b234301ebbbb19d700df0d4
DIST mcelog-179.tar.gz 315590 BLAKE2B 14de21330af412847ba627fccd41d20bdeb0f2f926ca81e7a564c4915cedccb8a2fe7c97227527a73ee0bfcc14757c30f67df47f26890319f4f6dae44551df4f SHA512 f9384abba55d5e6b181786feb28c72ba813d1d7b672b948f2e5c6cd6eaa11dd2ae6597301cd812f45a162f12fdabf7cb670daa325e5ab0cd072d99a880917981
+DIST mcelog-180.tar.gz 314605 BLAKE2B 0cf4f25dc26901bee56ddd437ad3d56874ba70f2323d9d6821432bf744b78392e871c9632e44a7bef7a1954eb6605cf72f6d9268397741cecd5066b6bcafe54a SHA512 89b2b1c2f7ab03bb358926f10fa2c3e8f048bb5cf2d6f4453de63ecfd44daebe771087522c69ade5638248ab79c80122448efef798e4ea8d1a5f88308e8bfd32
EBUILD mcelog-179-r1.ebuild 1071 BLAKE2B 773e4dceea91edcf4db65ee62b0359eeb3f84d75fd8d0867675b87d2e85ef3297277dc9750110e295e9f971268b58db6cfe3d08268a68c87b9b88836e52e7e36 SHA512 d08ef8c11b10d1945a04bbe081b35aa006352d095ba7919f6256eb0c299cc450dedc96d705fe64938f4fce4fda5369cbe1db14aa964909fe360278aeba4ed7ad
+EBUILD mcelog-180-r1.ebuild 1134 BLAKE2B b8cadda0b58b963a1cc75ad19bf32821b369ab4d33f307fd4814b64bc4c659331b9ac8c1e6bc4046bdbf76ec4853287f2bd292d9180e219fbe93fa0688ba4ce1 SHA512 36920c265132a7b99863e2ca9066ec2eb51a6760e4b0266c6bf52c0e394618541c58176c151a2409c7411520fb57e928537387f8d4ea437a75af9ba212e87f01
+EBUILD mcelog-180.ebuild 1025 BLAKE2B f1e19ea3d4cdc3b4279c2921fddb541ac1a687fefb4697db0a989b88acbec1aec03b5adbbbd8b2cf373f31e54b1f7199176a55b8600707977b3a36a60f63270e SHA512 39c7a5ec294a1b6223d78f0793ee23398d3d2cd782522614dbb70e70a22c7d65d4c3d522d67c1ff40fe14181815cfe1e81302174964f088fb8855989d8f2fb96
MISC metadata.xml 538 BLAKE2B 02cb85b3717b287e5e6a02db8c5485d52d1a5f7c9f927fad728ea8c313a93ebdb1aac5ac070cb852f18aae2cfebf5096ddb2c298948bc60180e4093c532aa899 SHA512 865e9e806a9fcf1d21ae7cd15c0e65196b3ccf7f866dc69237594908f020e224eca35d2d49fe70bef1e4d38b084ec8558e849148e470d3e22959f85177545bdc
diff --git a/app-admin/mcelog/mcelog-180-r1.ebuild b/app-admin/mcelog/mcelog-180-r1.ebuild
new file mode 100644
index 000000000000..b52399135375
--- /dev/null
+++ b/app-admin/mcelog/mcelog-180-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_9 python3_10)
+
+inherit linux-info python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="A tool to log and decode Machine Check Exceptions"
+HOMEPAGE="http://mcelog.org/"
+SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
+DEPEND="${PYTHON_DEPS}"
+
+# TODO: add mce-inject to the tree to support test phase
+RESTRICT="test"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ local CONFIG_CHECK="~X86_MCE"
+ kernel_is -ge 4 12 && CONFIG_CHECK+=" ~X86_MCELOG_LEGACY"
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
+ "${FILESDIR}"/${PN}-129-debugflags.patch
+ eapply_user
+ tc-export CC
+ python_fix_shebang genconfig.py
+}
+
+src_install() {
+ default
+
+ insinto /etc/logrotate.d/
+ newins ${PN}.logrotate ${PN}
+
+ newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
+ systemd_dounit ${PN}.service
+
+ dodoc *.pdf
+}
diff --git a/app-admin/mcelog/mcelog-180.ebuild b/app-admin/mcelog/mcelog-180.ebuild
new file mode 100644
index 000000000000..ec0ee80a3eff
--- /dev/null
+++ b/app-admin/mcelog/mcelog-180.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A tool to log and decode Machine Check Exceptions"
+HOMEPAGE="http://mcelog.org/"
+SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
+
+# TODO: add mce-inject to the tree to support test phase
+RESTRICT="test"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ local CONFIG_CHECK="~X86_MCE"
+ kernel_is -ge 4 12 && CONFIG_CHECK+=" ~X86_MCELOG_LEGACY"
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
+ "${FILESDIR}"/${PN}-129-debugflags.patch
+ eapply_user
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ insinto /etc/logrotate.d/
+ newins ${PN}.logrotate ${PN}
+
+ newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
+ systemd_dounit ${PN}.service
+
+ dodoc *.pdf
+}