summaryrefslogtreecommitdiff
path: root/app-admin/lsyncd/lsyncd-2.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/lsyncd/lsyncd-2.2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/lsyncd/lsyncd-2.2.1.ebuild')
-rw-r--r--app-admin/lsyncd/lsyncd-2.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/lsyncd/lsyncd-2.2.1.ebuild b/app-admin/lsyncd/lsyncd-2.2.1.ebuild
new file mode 100644
index 000000000000..4e14745a58b4
--- /dev/null
+++ b/app-admin/lsyncd/lsyncd-2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_IN_SOURCE_BUILD="YES_PLEASE_OMG"
+inherit cmake-utils
+
+DESCRIPTION="Live Syncing (Mirror) Daemon"
+HOMEPAGE="https://github.com/axkibe/lsyncd"
+SRC_URI="https://github.com/axkibe/lsyncd/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+
+CDEPEND=">=dev-lang/lua-5.1[deprecated]"
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ net-misc/rsync"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-mandir.patch
+)
+
+S=${WORKDIR}/${PN}-release-${PV}