summaryrefslogtreecommitdiff
path: root/app-admin/logrotate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-admin/logrotate
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-admin/logrotate')
-rw-r--r--app-admin/logrotate/Manifest2
-rw-r--r--app-admin/logrotate/logrotate-3.19.0.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/app-admin/logrotate/Manifest b/app-admin/logrotate/Manifest
index 0276e9db90a3..dc64d21125b4 100644
--- a/app-admin/logrotate/Manifest
+++ b/app-admin/logrotate/Manifest
@@ -2,5 +2,7 @@ AUX logrotate-3.15.0-ignore-hidden.patch 566 BLAKE2B 1739e0d175311eb2a3692826830
AUX logrotate.conf 740 BLAKE2B ade43681e1929aa8b7e167a2be0c8569f3842680687381c202ac04b5cf97cd85481f6ca7fbf6f0dffa64caa3b1d9cb0f1e2154af8882a3ce7008337f2a5ede6f SHA512 6411acd842fac1a8af72142cddfa76b567f6ba859bed91dab56f1d26b48f3dcaa3ffee6c8094860fe9c43f9b6bc398199c8f4047856b91d6d12333d0fc7aef96
AUX logrotate.tmpfiles 16 BLAKE2B 1f7925d6d2d4bc120d5202f49887b23e2eb633f5c369fe8d0bd1703e5075671dd1e13a030ec06fa269214bff9552670d3e0932e3dbde2e3673d59b7a50a2458b SHA512 f51852b1d5708a8fc48c6fcfd2fc4f34f3cd88d9119c607c0cb47f0cc0dc7370bd3399a9ebf781943cdd16a25bb4db0d81337140fc179faa72e18a848f3d8c36
DIST logrotate-3.18.1.tar.gz 225226 BLAKE2B 6f40dfe89f9c6202263f16204a9cff07b921abc9a298b58649bb4968c9f498626741be334c47d4092da564ed75642b687ff6ef8781f69f5e25364f8635646d9d SHA512 c40f920686aee014c652f087c64f2a85e9e866a8717d1bd3f32a9dd7959a02962e6174de28ae685428b442e12079d0c8d91485611ca34a873ffae872a54ec9fe
+DIST logrotate-3.19.0.tar.gz 228089 BLAKE2B aa5e932fe2056d150cc632134d80e160883b62e9f92a010bd5f5cded40a0362e28b966d006305b07030a8b07eb35a8e0c5b65b8d4bc87c278286b326cced1c46 SHA512 68bca961608565687a9ccb18e72f0627b405aff95286e508fdc78926d2cc172c56e1523a24ca81a161f683c2d568312984e2757edd291d144e0e4b982433e119
EBUILD logrotate-3.18.1-r1.ebuild 2259 BLAKE2B c24e5e395434a367bcfb58cd2dfc010f9d425c0b625a8e17b60ee2c79462f9713db9fd327bfad16c9219cc41de7f28df39e803494cef73f8c07d8e0bf18e67a3 SHA512 f58fa43a2710ebfea68f2568a935d4cbbcecf36df5db55d43910c68bea03f446693e1b4a0c615c9f23f686095682dec98d09caeb6c5f6aff98bfc4ee903a282c
+EBUILD logrotate-3.19.0.ebuild 2265 BLAKE2B f35ecd8332c1bb503a7cf9e110b2b3c9f6ebca8267dedbdd12252b055d5f0b3a8ddc4ebb9649d4af4bab4eb9653f0e21b33b9590f4d755b7b0309d4c2f40f51e SHA512 75bb941a6197e942e4c812044f86688baceaac813ecd35a22c040048924446dee29f71125279ca74ada9b0a3ed482a7eb26fabb6f5ac0b93951e477ffc4dfd68
MISC metadata.xml 1207 BLAKE2B 0d2ebf29e5ab5a01b2a8ac76ce1699e175d8fdba393ad97abad9cd3fbf9162042f253ab3551cde9273053c35b703e098d0501b67203da519b12258437d898f50 SHA512 3ac710f21ade3bb31767ea3e26b120a19a8ebfbfbcf5c66d30c888093428b0df026417e69d3823a2feaa27408b6015231f624b354df87ff50313edea39a0287b
diff --git a/app-admin/logrotate/logrotate-3.19.0.ebuild b/app-admin/logrotate/logrotate-3.19.0.ebuild
new file mode 100644
index 000000000000..00e473b5ae60
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.19.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://github.com/logrotate/logrotate"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="acl +cron selinux"
+
+DEPEND=">=dev-libs/popt-1.5
+ selinux? ( sys-libs/libselinux )
+ acl? ( virtual/acl )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-logrotate )
+ cron? ( virtual/cron )"
+
+STATEFILE="${EPREFIX}/var/lib/misc/logrotate.status"
+OLDSTATEFILE="${EPREFIX}/var/lib/logrotate.status"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.15.0-ignore-hidden.patch"
+)
+
+move_old_state_file() {
+ elog "logrotate state file is now located at ${STATEFILE}"
+ elog "See bug #357275"
+ if [[ -e "${OLDSTATEFILE}" ]] ; then
+ elog "Moving your current state file to new location: ${STATEFILE}"
+ mv -n "${OLDSTATEFILE}" "${STATEFILE}" || die
+ fi
+}
+
+install_cron_file() {
+ exeinto /etc/cron.daily
+ newexe "${S}"/examples/logrotate.cron "${PN}"
+}
+
+src_prepare() {
+ default
+
+ sed -i -e 's#/usr/sbin/logrotate#/usr/bin/logrotate#' examples/logrotate.{cron,service} || die
+}
+
+src_configure() {
+ econf \
+ $(use_with acl) \
+ $(use_with selinux) \
+ --with-state-file-path="${STATEFILE}"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin logrotate
+ doman logrotate.8
+ dodoc ChangeLog.md
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ use cron && install_cron_file
+
+ systemd_dounit examples/logrotate.{service,timer}
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ elog
+ elog "The ${PN} binary is now installed under /usr/bin. Please"
+ elog "update your links"
+ elog
+
+ move_old_state_file
+
+ tmpfiles_process ${PN}.conf
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+ fi
+}