summaryrefslogtreecommitdiff
path: root/app-admin/logcheck
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/logcheck
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/logcheck')
-rw-r--r--app-admin/logcheck/Manifest4
-rw-r--r--app-admin/logcheck/files/logcheck.cron10
-rw-r--r--app-admin/logcheck/logcheck-1.3.18-r1.ebuild62
-rw-r--r--app-admin/logcheck/metadata.xml5
4 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/logcheck/Manifest b/app-admin/logcheck/Manifest
new file mode 100644
index 000000000000..efa05d3680f1
--- /dev/null
+++ b/app-admin/logcheck/Manifest
@@ -0,0 +1,4 @@
+AUX logcheck.cron 184 BLAKE2B 5b773a77dace97e78efa565d8edf3bd715f564721ba0097e82a3894009fa86b6faffd3018a5270e224de2aefaaf07afa76c40b507d6ddffcf5ca4fb137ac6c09 SHA512 fd0b1bc8c836b766bfbb6102012996d27e378475571167b4d4df98301793624483aca2bd51ec19a2aa367e78b062ddde67355452db8dc1d69fe84a20a2081c30
+DIST logcheck_1.3.18.tar.xz 131252 BLAKE2B 024259d965c02d5f27a82f1df1e947d48e4b1bad705882243c4b743a1c061012f2437ecab1a97265f5a330fdec2f813a36c078dca282f54fdfaab03833340320 SHA512 3ab75969f732efa123d9df2c8b44557e4a7eddef8332a8357463930714148a13130c763c22e562bd60e106abf5e18cf39b3572e0c048727a117fbc67430b7e3f
+EBUILD logcheck-1.3.18-r1.ebuild 1366 BLAKE2B 3860c10cdb145ae50d9025117d38b7f330fb3cb730e37e86904bc57b860bf83c3cb90cf52af3b2cbc2566a851a02361148da4d049c48bdc017df34005780944e SHA512 fe6b92b43f853bdc1b61e05f8d0c1b1de4ced21e9160a99122bd588ed58711ebde62f9d5aba5f8cecba0ee9b550ce77f44e3373f271aa06c995826899421b2ed
+MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/app-admin/logcheck/files/logcheck.cron b/app-admin/logcheck/files/logcheck.cron
new file mode 100644
index 000000000000..3b3f4fcf62bd
--- /dev/null
+++ b/app-admin/logcheck/files/logcheck.cron
@@ -0,0 +1,10 @@
+#!/bin/bash
+
+set -e
+
+if [ ! -d /var/lock/logcheck ]; then
+ mkdir -p /var/lock/logcheck
+fi
+chown -R logcheck:logcheck /var/lock/logcheck
+
+su -s /bin/bash -c /usr/sbin/logcheck logcheck
diff --git a/app-admin/logcheck/logcheck-1.3.18-r1.ebuild b/app-admin/logcheck/logcheck-1.3.18-r1.ebuild
new file mode 100644
index 000000000000..eae9a3e73278
--- /dev/null
+++ b/app-admin/logcheck/logcheck-1.3.18-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit readme.gentoo-r1 user
+
+DESCRIPTION="Mails anomalies in the system logfiles to the administrator"
+HOMEPAGE="https://packages.debian.org/sid/logcheck"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !app-admin/logsentry
+ app-misc/lockfile-progs
+ dev-lang/perl
+ dev-perl/mime-construct
+ virtual/mailx
+"
+
+DOC_CONTENTS="
+ Please read the guide at https://wiki.gentoo.org/wiki/Logcheck
+ for installation instructions.
+"
+
+pkg_setup() {
+ enewgroup logcheck
+ enewuser logcheck -1 -1 -1 logcheck
+}
+
+src_prepare() {
+ default
+ # Add /var/log/messages support, bug #531524
+ echo "/var/log/messages" >> etc/logcheck.logfiles
+}
+
+src_install() {
+ default
+
+ # Do not install /var/lock, bug #449968 . Use rmdir to make sure
+ # the directories removed are empty.
+ rmdir "${D}/var/lock/logcheck" || die
+ rmdir "${D}/var/lock" || die
+
+ keepdir /var/lib/logcheck
+
+ readme.gentoo_create_doc
+ dodoc AUTHORS CHANGES CREDITS TODO docs/README.*
+ doman docs/logtail.8 docs/logtail2.8
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}/${PN}.cron"
+}
+
+pkg_postinst() {
+ chown -R logcheck:logcheck /etc/logcheck /var/lib/logcheck || die
+ readme.gentoo_print_elog
+}
diff --git a/app-admin/logcheck/metadata.xml b/app-admin/logcheck/metadata.xml
new file mode 100644
index 000000000000..7a38bb900964
--- /dev/null
+++ b/app-admin/logcheck/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>