summaryrefslogtreecommitdiff
path: root/app-admin/lnav/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 03:28:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 03:28:58 +0000
commitc73b611d606bc14760bad8592f5bfec28c9b1079 (patch)
tree6da7421d10ecff1c38c3774f9a9eed715711fd7c /app-admin/lnav/files
parentb9d995791a762215ef1ced2cc1a47b8d3c2cff1a (diff)
gentoo auto-resync : 14:12:2022 - 03:28:57
Diffstat (limited to 'app-admin/lnav/files')
-rw-r--r--app-admin/lnav/files/lnav-0.10.0-disable-tests.patch34
-rw-r--r--app-admin/lnav/files/lnav-0.10.1-gcc12.patch37
2 files changed, 0 insertions, 71 deletions
diff --git a/app-admin/lnav/files/lnav-0.10.0-disable-tests.patch b/app-admin/lnav/files/lnav-0.10.0-disable-tests.patch
deleted file mode 100644
index c7a49d45f1d7..000000000000
--- a/app-admin/lnav/files/lnav-0.10.0-disable-tests.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-# Certain tests commented out for stability reasons:
-# listview: Fails when building inside sandbox
-# mvattrline: Fails on some testers boxes. Documented here: https://github.com/tstack/lnav/issues/911
-# logfile: Flaky. Fails some times and not others. i.e. Race condition
-# tui: Can hang the build
---- a/test/Makefile.am
-+++ b/test/Makefile.am
-@@ -355,14 +355,14 @@
- test_cli.sh \
- test_cmds.sh \
- test_config.sh \
-- test_listview.sh \
-+ #test_listview.sh \
- test_meta.sh \
-- test_mvwattrline.sh \
-+ #test_mvwattrline.sh \
- test_grep_proc.sh \
- test_grep_proc2 \
- test_json_format.sh \
- test_log_accel \
-- test_logfile.sh \
-+ #test_logfile.sh \
- test_reltime \
- test_remote.sh \
- test_scripts.sh \
-@@ -376,7 +376,7 @@
- test_sql_str_func.sh \
- test_sql_time_func.sh \
- test_sql_xml_func.sh \
-- test_tui.sh \
-+ #test_tui.sh \
- test_data_parser.sh \
- test_pretty_print.sh \
- test_view_colors.sh \
diff --git a/app-admin/lnav/files/lnav-0.10.1-gcc12.patch b/app-admin/lnav/files/lnav-0.10.1-gcc12.patch
deleted file mode 100644
index 6ed4a73cebb2..000000000000
--- a/app-admin/lnav/files/lnav-0.10.1-gcc12.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://bugs.gentoo.org/839909
-https://github.com/tstack/lnav/pull/961
-
-From b8a31ae9b4bcd5690a2b3d2fbd6373caffbc4a57 Mon Sep 17 00:00:00 2001
-From: Peter Schiffer <3899107+pschiffe@users.noreply.github.com>
-Date: Mon, 21 Feb 2022 21:09:30 +0100
-Subject: [PATCH] Add `#include <iterator>` to `string_util.cc`
-
-Lnav fails to build on the next Fedora version due to the following error:
-```
-make[3]: Entering directory '/builddir/build/BUILD/lnav-0.10.1/src/base'
-g++ -std=c++14 -DHAVE_CONFIG_H -I. -I../../src -Wall -I../../src/ -I../../src/third-party -I../../src/fmtlib -I../../src/third-party/doctest-root -I/usr/local/include -D_ISOC99_SOURCE -D__STDC_LIMIT_MACROS -D_GNU_SOURCE -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -c -o string_util.o string_util.cc
-make[3]: Leaving directory '/builddir/build/BUILD/lnav-0.10.1/src/base'
-string_util.cc: In function 'std::string repeat(const std::string&, size_t)':
-string_util.cc:199:22: error: 'ostream_iterator' is not a member of 'std'
- 199 | std::fill_n(std::ostream_iterator<std::string>(os), num, input);
- | ^~~~~~~~~~~~~~~~
-string_util.cc:38:1: note: 'std::ostream_iterator' is defined in header '<iterator>'; did you forget to '#include <iterator>'?
- 37 | #include "string_util.hh"
- +++ |+#include <iterator>
- 38 |
-```
-
-Reason is probably the updated GNU toolchain, more info:
-https://fedoraproject.org/wiki/Changes/GNUToolchainF36
-
-This patch fixes the issue.
---- a/src/base/string_util.cc
-+++ b/src/base/string_util.cc
-@@ -29,6 +29,7 @@
-
- #include "config.h"
-
-+#include <iterator>
- #include <regex>
- #include <sstream>
-