summaryrefslogtreecommitdiff
path: root/app-admin/lib_users
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /app-admin/lib_users
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'app-admin/lib_users')
-rw-r--r--app-admin/lib_users/Manifest1
-rw-r--r--app-admin/lib_users/lib_users-0.14-r2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/lib_users/Manifest b/app-admin/lib_users/Manifest
index 3df3d2f294ae..4220be03bd7d 100644
--- a/app-admin/lib_users/Manifest
+++ b/app-admin/lib_users/Manifest
@@ -1,3 +1,4 @@
DIST lib_users-0.14.tar.gz 25746 BLAKE2B 4aa2dbbd7c53be13f79988a62c7997f0787ea9b773fc57681a021ff75ba9ff0988ac3032b21150c4e4958849a6195df09d388b6341e1ac139f34ce9555786233 SHA512 533c6e8f486e58d0fd22aea9a30adf91c3a8340a8a3719f6374ddfa8120d402c8202ab8ceb0e78aedd46e3e5875795392ed40497a66d51de5c2ca6a275a1a777
EBUILD lib_users-0.14-r1.ebuild 1094 BLAKE2B f4652e63165c1192e9db8e45266b3e827f01eae03487580511ba0afd694f60ea889b9c8120c96e23f9a7b7551c2b36f9701e5512e5b4ef80d35fa1f40de3ac36 SHA512 b1951af7ca2de0e3597e348bd714cdbaed4d9fe8c08f11a96bd220f7ddcb74789de68fbf463d937af6188c9f439e62673453427be2799941f9f4e5994b5e28b5
+EBUILD lib_users-0.14-r2.ebuild 1098 BLAKE2B 2c73bccf903a48e7866acd86c2fef04260ee4ace539b344abe81d98987a9d88c597b1dfcec45c3d68c01767c1fc7ae5cd7a50fd41fe781b049de0e10e511eca7 SHA512 d41d75b1f20a35073645e1270f4ac35e9a2ca3e25c3de2e81092058461a79e8ec93227167950858777b28776512dae0ca75ca86a3351d71bf077cfbaed5a4fc4
MISC metadata.xml 343 BLAKE2B 546650c71c7021908ec1f5ff61a835329bd7c9c870e9690565f9dd5dcfa2791c78334c3b7186cafb92f0f7b3900c44f37113062918346054bb11c4f54cb109d6 SHA512 890e9d42b29b85f62feae7d61cab7a0468a56df75fc0909bc0d5d0704bfe8052f9e524293011046fc2c8511378d3abb9928afa69ef35c51b79a4effae8ef9ebf
diff --git a/app-admin/lib_users/lib_users-0.14-r2.ebuild b/app-admin/lib_users/lib_users-0.14-r2.ebuild
new file mode 100644
index 000000000000..6d920f0bbaec
--- /dev/null
+++ b/app-admin/lib_users/lib_users-0.14-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit python-r1
+
+DESCRIPTION="Check for mapped libs and open files that are marked as deleted"
+HOMEPAGE="https://github.com/klausman/lib_users"
+SRC_URI="https://github.com/klausman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${PYTHON_DEPS}"
+
+src_test() {
+ python_foreach_impl nosetests --verbosity=2
+}
+
+my_install() {
+ python_newscript lib_users.py lib_users
+ python_newscript fd_users.py fd_users
+ # lib_users_util/ contains a test script we don't want, so do things by hand
+ python_moduleinto lib_users_util
+ python_domodule lib_users_util/common.py
+ python_domodule lib_users_util/__init__.py
+}
+
+src_install() {
+ python_foreach_impl my_install
+ dodoc README.md TODO
+}