summaryrefslogtreecommitdiff
path: root/app-admin/lib_users
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /app-admin/lib_users
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'app-admin/lib_users')
-rw-r--r--app-admin/lib_users/Manifest1
-rw-r--r--app-admin/lib_users/lib_users-0.15-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/lib_users/Manifest b/app-admin/lib_users/Manifest
index 7f2fe4ee9e32..a198eb5fc724 100644
--- a/app-admin/lib_users/Manifest
+++ b/app-admin/lib_users/Manifest
@@ -1,3 +1,4 @@
DIST lib_users-0.15.tar.gz 25899 BLAKE2B e54dfe20cf5e3e3da3bddcf044cda36a5d51dec9baa808202d81ed0ef8a8b434b3c6f31a279b544308a32e6ebf91008ac2db49278da7624a6037ffdf1db309b6 SHA512 f9eab0d7c634602c496154dc20bd8374842df77c6abfaf69a0c34013f01c3a7541a006cb2b027539f6c088a55bea78682bf156723899d614f39ee48773fb9ea8
+EBUILD lib_users-0.15-r1.ebuild 1072 BLAKE2B 33e9ef6355c00024b82214c524746657c96dea056b07edf97012bbedcc4c9f76c4ed54d2a611c15e7048302ca0401d2c33b2cfd28d11b3448dec46cef0c21875 SHA512 9312ad13bf338f19e726e1c770363b60683517c5b17d5388d9409a0a0ad4e9d0d0555cfe6df19f15050453090d0bf726e227ce3f9c16d7ea03a93c5fed07c938
EBUILD lib_users-0.15.ebuild 1066 BLAKE2B f458b98a2b2b8c3d96d7572ff9353118b0520cc2319a5172d43aca04b5308bdfcd71a0e93c15d74932b90805e27e1f02911fb134801654153c0fa84a61addcee SHA512 5172c79024c9cd0bb91d2707f93ce4e5c3f37b873146d8edfc6ea4998cb2ee19860d565a499a717d85089c8d6f74d9ca509556156d18838fe627fcf51489e2b0
MISC metadata.xml 344 BLAKE2B b11cff8e0077d50cf43e98a4c0502afec9c3c966f83513f392b97c1009fdaecbd73cb58ee8851e993e8e751f75f10adad6db97bf305d4f47afc016bb4b30f8d9 SHA512 ed9a5449f5efc28cdc6a615c889e2a312841db90524d3e12899c10824896f82535cc5c302b26525ed523f7e90cdf133edda0e3ee77f32563f3bfaad7b997301a
diff --git a/app-admin/lib_users/lib_users-0.15-r1.ebuild b/app-admin/lib_users/lib_users-0.15-r1.ebuild
new file mode 100644
index 000000000000..45ccbc10dde4
--- /dev/null
+++ b/app-admin/lib_users/lib_users-0.15-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-r1
+
+DESCRIPTION="Check for mapped libs and open files that are marked as deleted"
+HOMEPAGE="https://github.com/klausman/lib_users"
+SRC_URI="https://github.com/klausman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ dev-python/nose2[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${PYTHON_DEPS}"
+
+src_test() {
+ python_foreach_impl nose2 --verbosity=2
+}
+
+my_install() {
+ python_newscript lib_users.py lib_users
+ python_newscript fd_users.py fd_users
+ # lib_users_util/ contains a test script we don't want, so do things by hand
+ python_moduleinto lib_users_util
+ python_domodule lib_users_util/common.py
+ python_domodule lib_users_util/__init__.py
+}
+
+src_install() {
+ python_foreach_impl my_install
+ dodoc README.md TODO
+}