summaryrefslogtreecommitdiff
path: root/app-admin/lib_users
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:05:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:05:26 +0100
commit7b6779967898bf86cb9670457223f4237816a205 (patch)
tree2d2bf1b6b4222730e0e1e877b8038e2ae2eefbec /app-admin/lib_users
parent83c20bc401b9e577248523c6555493e36a100a41 (diff)
gentoo resync : 14.07.2018 (2nd step)
Diffstat (limited to 'app-admin/lib_users')
-rw-r--r--app-admin/lib_users/Manifest2
-rw-r--r--app-admin/lib_users/lib_users-0.11.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/lib_users/Manifest b/app-admin/lib_users/Manifest
index 52bd7f8d120d..a2ba079a443a 100644
--- a/app-admin/lib_users/Manifest
+++ b/app-admin/lib_users/Manifest
@@ -1,3 +1,5 @@
DIST lib_users-0.10.tar.gz 25636 BLAKE2B 6e660b80ef75f71d47f4783dc741e8b0c17f3cfe31296c5624adcfed5836a0b86964f042eafb5b34e259a824c79efb537558d625bc16d07fb388d61ece7c6329 SHA512 dee8203457570f686df69dc91d71614b462845c848a3445fd9b9f94047fdba8171cc2555fa4299bc4c361905d488c1f17cee4ab0e99899f37995377d6011805a
+DIST lib_users-0.11.tar.gz 25660 BLAKE2B 8f5a827840d4074a0e8abd77e43f60eb09f199f58a2bde0c2bce7613d6ba1d9b12dd46adffa528ff351f54933c304f274abef9c35550d7af3519101dcec69d0a SHA512 a54fc8f57cffcd08e77e86eaf50ec6e68e45e1e9458e25e035af90e14be13980a400c4d264f70ef67e141e1d54581b0487b2b70dd084dc5840424221b46f644a
EBUILD lib_users-0.10.ebuild 1117 BLAKE2B 511c6cc9302552d0f0c70221ed81079f64b8a8fc9bf35541d03130769981f5d96a2243fccaf122b9d2875d5fbc794e094ebbdd3a56a33ccbdf1f8b0ccd844033 SHA512 d5e8f63944f2b7e6cc6bb34b170f59b534cc5c6c8346ade237110a621e27dc2253969ec969321d5567e6d0e70dc9a3d57219321d41cbe27462e109b590c2a605
+EBUILD lib_users-0.11.ebuild 1123 BLAKE2B a598c57cb898438aa386a80b9a9445ecae5372ee8617ef5c2447a3319bb4af87fe78ad361a9a0d2dfb8067811d3fde8f6f28b6de23a6ab9ef55044e19f96d6a2 SHA512 f1f0a4725a1897951f9f61099b810c846419689c00e6dccbac5efaeace57f31cfb03c042f53ccb652f7be75fdcab5308a9106094e04bc3802f4f6de96f145740
MISC metadata.xml 454 BLAKE2B c545fd1db330988ad139de08b1890cfd9d6aac98947b954fb761515d314d8ebb941829e7767fe4fad6beb41caf3409111505d1a6378c852f15907933678ddd48 SHA512 c897ea5b6bed9fcc8715380a1b2756f376a095925a2c99a78ce6729cc9839683f40ce53f5faf0fb784169db5ef9162f1659ea6f24304bcc7cd47f90d49ec97dd
diff --git a/app-admin/lib_users/lib_users-0.11.ebuild b/app-admin/lib_users/lib_users-0.11.ebuild
new file mode 100644
index 000000000000..32a7d7827f37
--- /dev/null
+++ b/app-admin/lib_users/lib_users-0.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="Check for mapped libs and open files that are marked as deleted"
+HOMEPAGE="https://github.com/klausman/lib_users"
+SRC_URI="https://github.com/klausman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${PYTHON_DEPS}"
+
+src_test() {
+ python_foreach_impl nosetests --verbosity=2
+}
+
+my_install() {
+ python_newscript lib_users.py lib_users
+ python_newscript fd_users.py fd_users
+ # lib_users_util/ contains a test script we don't want, so do things by hand
+ python_moduleinto lib_users_util
+ python_domodule lib_users_util/common.py
+ python_domodule lib_users_util/__init__.py
+}
+
+src_install() {
+ python_foreach_impl my_install
+ dodoc README.md TODO
+}