summaryrefslogtreecommitdiff
path: root/app-admin/keepass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /app-admin/keepass
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/Manifest2
-rw-r--r--app-admin/keepass/keepass-2.47.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 38c031847d71..810855bf0a51 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,5 +1,7 @@
AUX keepass-2.36-xsl-path-detection.patch 1446 BLAKE2B 15c9d15b44b0748bc114ff45dadb5824f369a454a1126cb61293d55f86f9f01fb659932729dbc205a522aab32343dd87b74662927d60edc50750af602a959cc9 SHA512 6e1279363bf355be8846c012840271525dcbeccfaa9dc9d1bc4b39068ed58dae4fc421fed4f0fd5d0d2311436d35648f04539fa122066222cb15a66c3383ceae
AUX keepass.xml 275 BLAKE2B 8e64d7e60b0808b9505387caf97c9198d14ead3510c72d3a62cb747a2f09a64f63360f95df12043a97262fde8fd1b6882fe86d07d4ec483cf30788391be8f940 SHA512 a6055604ff4ff9e905012b5f8448540ea3b3fa8527ce1fd247fe4e5329e6861e5e7a01ea5ed907c41c073d81ee02452392ea0b0d61bf1119dadd300911a450fb
DIST KeePass-2.46-Source.zip 5054069 BLAKE2B 81567ab4589e53ae5cc1b75fa42cc61d9d0f390edfa8f8d860dd118a95185a8d2ca417b30b29e2b544b1d4eeeb0069fab2f0be7900fd4d7fb87d41c417b99876 SHA512 ca045cb7363092f948d72243991fe398836b13183cc2685477d7ce5dd629213b5803b4216134c7ba6451726b79ca43d1e93a1934c9cbff46293fa916b9348219
+DIST KeePass-2.47-Source.zip 5100005 BLAKE2B 9a71706efbb734244a0de6e1ba705ebaeb550368a77b1e74eaae47ec5a9c7dd12139740d7502dd5ad40e6b90e179f037ca5eae1650c2659a0a64260a93cd595f SHA512 df0f4dc9702198b4d31e78ac4fa1e85746dc7618529ab5ceaae1f6e1cc68a9a574f7892caff99e767f583fe102d87f0bfaf579f375eb227bf6f28fce6253a8f1
EBUILD keepass-2.46.ebuild 3228 BLAKE2B 58d0e7a54ee7aace849c916e08b45bd6e1e5e838982f54efaccecea3279eee65aefcbbe6a3291828bbb769f938b09ea5a644b4a85667f2420bda90a2743e1c7d SHA512 ea1e5e8addbf66756fe812bddc29d4c8da359bb68f03ba1322f517a36d6839e4e7972628676108efb23ffcec64a42266f848854c55a79a8f7a971a2ac904633c
+EBUILD keepass-2.47.ebuild 3230 BLAKE2B b86c31397b4cfd3865ee5ae47f9649724a9c3acc594a4ffbd54c59fc4ecf0b6bb958a579a85635305f2c87db3ed7bc5b48b48bc44a2beebeaf850a03bb7a76c3 SHA512 890c87ca3b874f0c2a35f390feed32ef281233bb339df9bd1c2bf75a49580d52aaca2315f1b1128b8b0db81a6ea31235541bb45b402f9595fa67689f6eab2337
MISC metadata.xml 651 BLAKE2B 058fa70fb6ce35fb52464a84cf506ad117343a1376a40b003c4f55bdf94369136276d8bbb67f30490eb73cba4df6b03d78e8c2a65cf8141dd6cf64654c9b6358 SHA512 6251f546e631decbc7692ab00900d722031ce638f3d878771a2bcfebedba8e1fee9b3e54dfd4c3ae3c711006099fc5a772555ea7cc018d012de164755ba8b52c
diff --git a/app-admin/keepass/keepass-2.47.ebuild b/app-admin/keepass/keepass-2.47.ebuild
new file mode 100644
index 000000000000..af7035cf7b4b
--- /dev/null
+++ b/app-admin/keepass/keepass-2.47.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="https://keepass.info/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aot"
+
+COMMON_DEPEND="dev-lang/mono"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-dotnet/libgdiplus[cairo]
+"
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
+
+# bug #687052
+# file generated by mono --aot where *FLAGS don't make sense
+QA_PREBUILT="usr/lib64/keepass/KeePass.exe.so"
+
+src_prepare() {
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
+ # This XSL file will not be upstreamed since the KeePass creator said that
+ # including this patch would break the Portable USB version of KeePass
+ # (which keeps/looks for xsl files in its own folder)
+ default
+
+ # Switch into build dir so the mono prepration script works correctly
+ pushd Build || die
+ source PrepMonoDev.sh || die
+ popd || die
+}
+
+src_compile() {
+ export MONO_REGISTRY_PATH=/dev/null # bug 659808
+
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto "/usr/share/${PN}/XSL"
+ doins Ext/XSL/*
+
+ insinto "/usr/$(get_libdir)/${PN}"
+ exeinto "/usr/$(get_libdir)/${PN}"
+
+ doins Ext/KeePass.exe.config
+
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}.xml"
+
+ # sed, because patching this really sucks
+ sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ if ! has_version x11-misc/xdotool ; then
+ elog "Optional dependencies:"
+ elog " x11-misc/xdotool (enables autotype/autofill)"
+ fi
+
+ elog "Some systems may experience issues with copy and paste operations."
+ elog "If you encounter this, please install x11-misc/xsel."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}