summaryrefslogtreecommitdiff
path: root/app-admin/keepass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /app-admin/keepass
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/Manifest1
-rw-r--r--app-admin/keepass/keepass-2.40-r1.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 03ee3189ae80..32c0f77f0fef 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -5,5 +5,6 @@ DIST KeePass-2.39.1-Source.zip 5109228 BLAKE2B 0b1214ac70d3d615e029c89abe63176f3
DIST KeePass-2.40-Source.zip 5136918 BLAKE2B 7b5071cbe3bc5f20450a094a4b8969e2e25f6bba27d88ee5c2c25f2706ed3cf18e721ba53ff54c78db6ea1e167cef1108611fc8253a9d6e19eb3f9d1f3317c73 SHA512 222f7e7ef65be8b0d75baa0a6e871d5edad1b570b64f261405b843d7387ec1faeb4138afb8b31934d70eebe0add297681028cb4f3acfcbe4f518c763fe6c0145
EBUILD keepass-2.38.ebuild 3037 BLAKE2B 3fe5b971d8336ffdc3f9b520ac3c4530cdee3555c3e20cf7658ddb6fc874b28d1ee5710d76de2282128e83c84f05b5b2435db657e9be278ce4ed7ea107b6829a SHA512 f2f473c7fcde5e11711c3519c72ad78f2853ac6e7c242da2be9aa34e74e8d7962e2416e48a827b5a6d6e9b6f91314b426e662cbdc2e01e9c2d8e9331120f10a7
EBUILD keepass-2.39.1.ebuild 3044 BLAKE2B 9585f72e1556fd9d033ee8dafb3a6baeca0e1aad2c318367f6dcadb102a0557890e422679529b3f3d61ebdf5120a49eda13553326f5b5a919d6245edeb927e77 SHA512 143239c46dc87d69859beaf7b3ef621d4793c6341871e7c325058529b00c4a1a5da297b42d1e4dc0788eb7e80a2b27d47f02bbdd9758050aab1615f02de8245d
+EBUILD keepass-2.40-r1.ebuild 3067 BLAKE2B ac3e7eb4b4ffb515bad007aed19a1259b96caff907923e6792d4988fbb0c045639bce852502a7843c7b22791a1ffe27bbf748b118f4842a7f11847f2f6786bfd SHA512 19ad84df5e6de4d238c4bc07e4c15377945a966222d6ea25863b364be1882b154a6b6e4514b7c7820b69b13f4a3e2cbf4ebe852efbf1ef7d72f4e6b06ece3901
EBUILD keepass-2.40.ebuild 3044 BLAKE2B 9585f72e1556fd9d033ee8dafb3a6baeca0e1aad2c318367f6dcadb102a0557890e422679529b3f3d61ebdf5120a49eda13553326f5b5a919d6245edeb927e77 SHA512 143239c46dc87d69859beaf7b3ef621d4793c6341871e7c325058529b00c4a1a5da297b42d1e4dc0788eb7e80a2b27d47f02bbdd9758050aab1615f02de8245d
MISC metadata.xml 651 BLAKE2B 058fa70fb6ce35fb52464a84cf506ad117343a1376a40b003c4f55bdf94369136276d8bbb67f30490eb73cba4df6b03d78e8c2a65cf8141dd6cf64654c9b6358 SHA512 6251f546e631decbc7692ab00900d722031ce638f3d878771a2bcfebedba8e1fee9b3e54dfd4c3ae3c711006099fc5a772555ea7cc018d012de164755ba8b52c
diff --git a/app-admin/keepass/keepass-2.40-r1.ebuild b/app-admin/keepass/keepass-2.40-r1.ebuild
new file mode 100644
index 000000000000..2e9012f82203
--- /dev/null
+++ b/app-admin/keepass/keepass-2.40-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils xdg-utils
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="https://keepass.info/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aot"
+
+COMMON_DEPEND="dev-lang/mono"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-dotnet/libgdiplus[cairo]
+"
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
+
+src_prepare() {
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
+ # This XSL file will not be upstreamed since the KeePass creator said that
+ # including this patch would break the Portable USB version of KeePass
+ # (which keeps/looks for xsl files in its own folder)
+ default
+
+ # Switch into build dir so the mono prepration script works correctly
+ pushd Build || die
+ source PrepMonoDev.sh || die
+ popd || die
+}
+
+src_compile() {
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto "/usr/share/${PN}/XSL"
+ doins Ext/XSL/*
+
+ insinto "/usr/$(get_libdir)/${PN}"
+ exeinto "/usr/$(get_libdir)/${PN}"
+
+ doins Ext/KeePass.exe.config
+
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}.xml"
+
+ # sed, because patching this really sucks
+ sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ if ! has_version x11-misc/xdotool ; then
+ elog "Optional dependencies:"
+ elog " x11-misc/xdotool (enables autotype/autofill)"
+ fi
+
+ elog "Some systems may experience issues with copy and paste operations."
+ elog "If you encounter this, please install x11-misc/xsel."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}