summaryrefslogtreecommitdiff
path: root/app-admin/keepass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /app-admin/keepass
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/Manifest2
-rw-r--r--app-admin/keepass/keepass-2.46.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 6acd98bf5516..0c961cfdcdb2 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -2,6 +2,8 @@ AUX keepass-2.36-xsl-path-detection.patch 1446 BLAKE2B 15c9d15b44b0748bc114ff45d
AUX keepass.xml 275 BLAKE2B 8e64d7e60b0808b9505387caf97c9198d14ead3510c72d3a62cb747a2f09a64f63360f95df12043a97262fde8fd1b6882fe86d07d4ec483cf30788391be8f940 SHA512 a6055604ff4ff9e905012b5f8448540ea3b3fa8527ce1fd247fe4e5329e6861e5e7a01ea5ed907c41c073d81ee02452392ea0b0d61bf1119dadd300911a450fb
DIST KeePass-2.44-Source.zip 5182922 BLAKE2B 092d1b982d748ea1b13f26fe5423a491855cb491c80cae7632429d488f80fd730df5d2f1613bab528d55a3aadcf0cb4f4055a637d2b14b68a468e4baf9ab1837 SHA512 ef2ca69e40c0787b63fc30a2b222dd77fd9f0addf8593511dcd0a47580cc8de5e0900c7d4e6f77c0e5a49d1728286cf1b5856cdc65ef175e4acfdd1ffc54b55e
DIST KeePass-2.45-Source.zip 5011684 BLAKE2B cf7fafb2666f2e0005533e441f1855006aa64aca69b4829fa66117da88f92e6aa65d58b303a099221e796a500bc5abab5c3d0654e6fa53c3fe6f36d3cb18e381 SHA512 3f9b14e57fce047f8d8ae7c289fffd954545c5638fa20392e7864301073452a4353f487832730fb600e1729b1333360c1bce7e66fc8629788e666418a2afbf9a
+DIST KeePass-2.46-Source.zip 5054069 BLAKE2B 81567ab4589e53ae5cc1b75fa42cc61d9d0f390edfa8f8d860dd118a95185a8d2ca417b30b29e2b544b1d4eeeb0069fab2f0be7900fd4d7fb87d41c417b99876 SHA512 ca045cb7363092f948d72243991fe398836b13183cc2685477d7ce5dd629213b5803b4216134c7ba6451726b79ca43d1e93a1934c9cbff46293fa916b9348219
EBUILD keepass-2.44.ebuild 3228 BLAKE2B 58d0e7a54ee7aace849c916e08b45bd6e1e5e838982f54efaccecea3279eee65aefcbbe6a3291828bbb769f938b09ea5a644b4a85667f2420bda90a2743e1c7d SHA512 ea1e5e8addbf66756fe812bddc29d4c8da359bb68f03ba1322f517a36d6839e4e7972628676108efb23ffcec64a42266f848854c55a79a8f7a971a2ac904633c
EBUILD keepass-2.45.ebuild 3229 BLAKE2B 804f64ae148cb8fc30a9278b9dd1e90e2e9fbc966432e708bdfe3210f4bbd7863ab4fce8f4131d788525331777a3991b02ebe1202e4365414dd57370987a4b6e SHA512 12fa7978a687562145af54e3730ab832f50f732b56b3c76927e3286cf1fb24c0f7dac3ba2ac984560c56449b3845c073ac99aba457d5b51bda1eccd14ed5a6e2
+EBUILD keepass-2.46.ebuild 3230 BLAKE2B 9e3c55cb5220c18d7044de21d21cd96a1ad5f145ecf627d1db444ed5a187bc97aad27332c1e7a841c8153ae86eec2dc50f48a00567e681714b3354fc81b1c965 SHA512 b1c53ec9a3f97156823bb6c9265f0fa89b7c000a943557dfe3ba5a19eeec36657d537340692eeaccbf61b3af8508785b78cc0615595775b1e9074a285d53605a
MISC metadata.xml 651 BLAKE2B 058fa70fb6ce35fb52464a84cf506ad117343a1376a40b003c4f55bdf94369136276d8bbb67f30490eb73cba4df6b03d78e8c2a65cf8141dd6cf64654c9b6358 SHA512 6251f546e631decbc7692ab00900d722031ce638f3d878771a2bcfebedba8e1fee9b3e54dfd4c3ae3c711006099fc5a772555ea7cc018d012de164755ba8b52c
diff --git a/app-admin/keepass/keepass-2.46.ebuild b/app-admin/keepass/keepass-2.46.ebuild
new file mode 100644
index 000000000000..db354f613661
--- /dev/null
+++ b/app-admin/keepass/keepass-2.46.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="https://keepass.info/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aot"
+
+COMMON_DEPEND="dev-lang/mono"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-dotnet/libgdiplus[cairo]
+"
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
+
+# bug #687052
+# file generated by mono --aot where *FLAGS don't make sense
+QA_PREBUILT="usr/lib64/keepass/KeePass.exe.so"
+
+src_prepare() {
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
+ # This XSL file will not be upstreamed since the KeePass creator said that
+ # including this patch would break the Portable USB version of KeePass
+ # (which keeps/looks for xsl files in its own folder)
+ default
+
+ # Switch into build dir so the mono prepration script works correctly
+ pushd Build || die
+ source PrepMonoDev.sh || die
+ popd || die
+}
+
+src_compile() {
+ export MONO_REGISTRY_PATH=/dev/null # bug 659808
+
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto "/usr/share/${PN}/XSL"
+ doins Ext/XSL/*
+
+ insinto "/usr/$(get_libdir)/${PN}"
+ exeinto "/usr/$(get_libdir)/${PN}"
+
+ doins Ext/KeePass.exe.config
+
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}.xml"
+
+ # sed, because patching this really sucks
+ sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ if ! has_version x11-misc/xdotool ; then
+ elog "Optional dependencies:"
+ elog " x11-misc/xdotool (enables autotype/autofill)"
+ fi
+
+ elog "Some systems may experience issues with copy and paste operations."
+ elog "If you encounter this, please install x11-misc/xsel."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}