summaryrefslogtreecommitdiff
path: root/app-admin/keepass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
commit343a7272d559a21a0e0ed13cb743fabb2bfcc479 (patch)
treedb03f20672a6244296ccc2aa27e70757937eb9f7 /app-admin/keepass
parent456dbeaab3e2f71f527eae542ab44d1e372b0655 (diff)
gentoo resync : 11.01.2018
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/Manifest2
-rw-r--r--app-admin/keepass/keepass-2.38.ebuild111
2 files changed, 113 insertions, 0 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 5a3f88fc2b47..946b1ed300c6 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,5 +1,7 @@
AUX keepass-2.36-xsl-path-detection.patch 1446 BLAKE2B 15c9d15b44b0748bc114ff45dadb5824f369a454a1126cb61293d55f86f9f01fb659932729dbc205a522aab32343dd87b74662927d60edc50750af602a959cc9 SHA512 6e1279363bf355be8846c012840271525dcbeccfaa9dc9d1bc4b39068ed58dae4fc421fed4f0fd5d0d2311436d35648f04539fa122066222cb15a66c3383ceae
AUX keepass.xml 275 BLAKE2B 8e64d7e60b0808b9505387caf97c9198d14ead3510c72d3a62cb747a2f09a64f63360f95df12043a97262fde8fd1b6882fe86d07d4ec483cf30788391be8f940 SHA512 a6055604ff4ff9e905012b5f8448540ea3b3fa8527ce1fd247fe4e5329e6861e5e7a01ea5ed907c41c073d81ee02452392ea0b0d61bf1119dadd300911a450fb
DIST KeePass-2.37-Source.zip 5080663 BLAKE2B bf74c93eb732d607fe87dc29d3e429b37f1052b258e980127ce1f687423a790bfe298f06c1c459888c60b066a45053447fbaed730e3d38cd6b6dd48d53fbdc34 SHA512 d094793a3216181ae375fb1343a809a20c358786bdf369c0171e5b7ca17a74bada314875cf410d84efaa4fa2b13e199de9be3c60f5f4e2c189241e4fffec8ad8
+DIST KeePass-2.38-Source.zip 5091900 BLAKE2B 22e3f7046984204a3e0c4a1c6d8303661048bc0fee4bcdb7999b521d0ed6e5463d89044d2897cfec0c932349cc80a7b43d4c8dfbceb4f2e88041c642e0c0d231 SHA512 42fa7274874d4858da360a6772eb25adbf3a6dafe375093459d9a25903d8c159360ea722e969fe8b330bccf62ee5d381e131bd0ba075445932d8019eee19bf20
EBUILD keepass-2.37.ebuild 3036 BLAKE2B a1abedf46c4471659192b6b0aea80799ecc5318230305ca3a50721907a5366a2b5c52c5f6ec4ca4f08fdafe091bc648ac10f3099632238daee9dee619429ae57 SHA512 d4320aae524fe146ece9b319d5e94382197012e3f38f18a7213c5b6b82ff4d68f0bb36a1eb57cb978c7d6ce04339cefdb4e751127c53d470ed27c086e8389174
+EBUILD keepass-2.38.ebuild 3038 BLAKE2B 4c2c5cd80283d80b0ece5cfc8cb44703c9cae8c0677864d48a8c39816c26c5d4821157ef6625901dccb307195b9fa06e36a7c5dfdbad1bfb053b0abcc3143b0c SHA512 ea268f6f27b0d224de6bcbc002f0006702fe8cf30ba4e4d50a6c2d66ba4dbbdcf689232705662683dd620639a76201757e6bcd71e5069ed716767bc31167ed2f
MISC metadata.xml 791 BLAKE2B 5372f9ae70aaca07a660beeddb0a6a07f8fcc2f7a5d0d66ac4ed6b05a1f4ee0e21f14a29b2b3adf548e91d6187ec2ccf8047b307aaef03ec3d3a6936b0120d60 SHA512 fb4fe73e3a2f4d36f36ecae7b9c13dc48db967cced94f0741bd6a2ae91d2a1d502ef9d2c9ace534c866268829d430f91a79f1e7ead89d03cbdfd4a94b89df861
diff --git a/app-admin/keepass/keepass-2.38.ebuild b/app-admin/keepass/keepass-2.38.ebuild
new file mode 100644
index 000000000000..03c01b537dff
--- /dev/null
+++ b/app-admin/keepass/keepass-2.38.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils xdg-utils
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="http://keepass.info/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aot"
+
+COMMON_DEPEND="dev-lang/mono"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-dotnet/libgdiplus[cairo]
+"
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
+
+src_prepare() {
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
+ # This XSL file will not be upstreamed since the KeePass creator said that
+ # including this patch would break the Portable USB version of KeePass
+ # (which keeps/looks for xsl files in its own folder)
+ default
+
+ # Switch into build dir so the mono prepration script works correctly
+ cd Build || die
+ source PrepMonoDev.sh || die
+ cd ../ || die
+}
+
+src_compile() {
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto "/usr/share/${PN}/XSL"
+ doins Ext/XSL/*
+
+ insinto "/usr/$(get_libdir)/${PN}/"
+ exeinto "/usr/$(get_libdir)/${PN}/"
+
+ doins Ext/KeePass.exe.config
+
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages/
+ doins "${FILESDIR}/${PN}.xml"
+
+ # sed, because patching this really sucks
+ sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ if ! has_version x11-misc/xdotool ; then
+ elog "Optional dependencies:"
+ elog " x11-misc/xdotool (enables autotype/autofill)"
+ fi
+
+ elog "Some systems may experience issues with copy and paste operations."
+ elog "If you encounter this, please install x11-misc/xsel."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}