summaryrefslogtreecommitdiff
path: root/app-admin/installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-06 11:18:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-06 11:18:16 +0100
commitebce8994fe3cc4ca9fbc96ca837cb4c4e98adcbd (patch)
treef2204ce5f94dc3cb13728ff93649d889944952bb /app-admin/installer
parentfe1c8b732bd548b699d4c2ef725f67f8b8c8911c (diff)
gentoo resync : 06.05.2018
Diffstat (limited to 'app-admin/installer')
-rw-r--r--app-admin/installer/Manifest3
-rw-r--r--app-admin/installer/installer-0.1.1_beta.ebuild21
-rw-r--r--app-admin/installer/metadata.xml18
3 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/installer/Manifest b/app-admin/installer/Manifest
new file mode 100644
index 000000000000..684cfdd817ae
--- /dev/null
+++ b/app-admin/installer/Manifest
@@ -0,0 +1,3 @@
+DIST installer-0.1.1_beta.tar.gz 49946 BLAKE2B 845df010036446e65479affc3d901fe114248130627ce76583c42adc9ecf9c0e2585600106c1559c8d3dac8c086553fed1d48d00002ede9e9be509fc98632662 SHA512 940272cefed17bd6c370fe26b2941da611cbd0aa8fb1c7f51bfaef483c7f9189f10754fb7e3d84dc099ac687f4644e24ae22e7ec09c41f39efba30d5743c9163
+EBUILD installer-0.1.1_beta.ebuild 510 BLAKE2B 7acaa90f301624538d4ee8a9b2832ee3dc7408fe2c04796741882bd6afce46c3caf8ee17282ec112ee8cfc1072f8c85e4190e84d72b0db63c783e48e30381932 SHA512 e1f449f4b8199c531b36d2baed33d6e4541c857a4931f470afa262c5199ba6cf39bd92bc554de63efe01efac6ae160baac6a8fedfae3d8e366913d48ff9b1da0
+MISC metadata.xml 650 BLAKE2B 85405d55a8203f929a0a11864b7df6ddb9763160da824a1a1f037c1ea3e52f3a1fd1540316142f47af0ed575f90deab90fc71a90085ac1ba3f571954d079f541 SHA512 d1c0b0a1fe0b4aa0fb00595d7c46c73254ee22bd801b81a9895e176a0577ae64174dd587bacd3ac5ca17fe6c56f771274d508f9249a990608e6b515bc8aabef2
diff --git a/app-admin/installer/installer-0.1.1_beta.ebuild b/app-admin/installer/installer-0.1.1_beta.ebuild
new file mode 100644
index 000000000000..0b585a450e7d
--- /dev/null
+++ b/app-admin/installer/installer-0.1.1_beta.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_REQ_USE="ncurses(+)"
+
+inherit distutils-r1
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A software for Gentoo installation"
+HOMEPAGE="https://github.com/ChrisADR/installer"
+SRC_URI="mirror://github.com/ChrisADR/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+DOCS=( README.md CONTRIBUTING.md )
diff --git a/app-admin/installer/metadata.xml b/app-admin/installer/metadata.xml
new file mode 100644
index 000000000000..b6fd5038e019
--- /dev/null
+++ b/app-admin/installer/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chrisadr@gentoo.org</email>
+ <name>Christopher Díaz Riveros</name>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ installer is designed to aid users during the installation
+ process of Gentoo Linux. It is capable of walk a beginner
+ user through the regular installation process following key
+ topics from the Gentoo Handbook.
+ </longdescription>
+</pkgmetadata>