summaryrefslogtreecommitdiff
path: root/app-admin/installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/installer
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/installer')
-rw-r--r--app-admin/installer/Manifest3
-rw-r--r--app-admin/installer/installer-0.1.1_beta.ebuild21
-rw-r--r--app-admin/installer/metadata.xml18
3 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/installer/Manifest b/app-admin/installer/Manifest
new file mode 100644
index 000000000000..706920095904
--- /dev/null
+++ b/app-admin/installer/Manifest
@@ -0,0 +1,3 @@
+DIST installer-0.1.1_beta.tar.gz 49946 BLAKE2B 845df010036446e65479affc3d901fe114248130627ce76583c42adc9ecf9c0e2585600106c1559c8d3dac8c086553fed1d48d00002ede9e9be509fc98632662 SHA512 940272cefed17bd6c370fe26b2941da611cbd0aa8fb1c7f51bfaef483c7f9189f10754fb7e3d84dc099ac687f4644e24ae22e7ec09c41f39efba30d5743c9163
+EBUILD installer-0.1.1_beta.ebuild 512 BLAKE2B b93b2f2fcd04f5a1780586bd031dafa942093605a531020e29531c81541589ce4f584bdd2ad738e78fd09bc356de295cb3b2fded1b4ade719a430b0e4928d02e SHA512 19698b48f8d34be506c2386473f3b552498ebf8283c6e4b09297612aa952c5c758ac0a4524262bde471ed703a2199be1a1b153e97dce1823a443749df596eb7d
+MISC metadata.xml 650 BLAKE2B 85405d55a8203f929a0a11864b7df6ddb9763160da824a1a1f037c1ea3e52f3a1fd1540316142f47af0ed575f90deab90fc71a90085ac1ba3f571954d079f541 SHA512 d1c0b0a1fe0b4aa0fb00595d7c46c73254ee22bd801b81a9895e176a0577ae64174dd587bacd3ac5ca17fe6c56f771274d508f9249a990608e6b515bc8aabef2
diff --git a/app-admin/installer/installer-0.1.1_beta.ebuild b/app-admin/installer/installer-0.1.1_beta.ebuild
new file mode 100644
index 000000000000..17bc218aa0e4
--- /dev/null
+++ b/app-admin/installer/installer-0.1.1_beta.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="ncurses(+)"
+
+inherit distutils-r1
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A software for Gentoo installation"
+HOMEPAGE="https://github.com/ChrisADR/installer"
+SRC_URI="https://github.com/ChrisADR/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+DOCS=( README.md CONTRIBUTING.md )
diff --git a/app-admin/installer/metadata.xml b/app-admin/installer/metadata.xml
new file mode 100644
index 000000000000..b6fd5038e019
--- /dev/null
+++ b/app-admin/installer/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chrisadr@gentoo.org</email>
+ <name>Christopher Díaz Riveros</name>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ installer is designed to aid users during the installation
+ process of Gentoo Linux. It is capable of walk a beginner
+ user through the regular installation process following key
+ topics from the Gentoo Handbook.
+ </longdescription>
+</pkgmetadata>