summaryrefslogtreecommitdiff
path: root/app-admin/ide-smart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-admin/ide-smart
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-admin/ide-smart')
-rw-r--r--app-admin/ide-smart/Manifest3
-rw-r--r--app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch17
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r1.ebuild22
3 files changed, 36 insertions, 6 deletions
diff --git a/app-admin/ide-smart/Manifest b/app-admin/ide-smart/Manifest
index 8eaf5c59c769..ead0b6dbe7ce 100644
--- a/app-admin/ide-smart/Manifest
+++ b/app-admin/ide-smart/Manifest
@@ -1,4 +1,5 @@
+AUX ide-smart-1.4-fix-build-system.patch 280 BLAKE2B feac0eeafdc202a7f0074c6ca8c102f5602bcd1b9ec734e605d122464c9e782db1efd502677d415b1620090a82b5ee70755e25bf478700eb6b89d059a9ba5bf4 SHA512 7b27a8842d0ac7834d660f1ef46563a210a37e737c469cfae0ec07d18ae6fa523b6482f8fcba3f63247742c86215e01a35294ea664a416e7ffa92184c91b8c03
DIST ide-smart-1.4.tar.gz 19739 BLAKE2B d9c94b53855628ea10ea563f709754e7f79e50d43e24f76ac3c6dc9b5bdee81a547e63c4583c3506cc899c7e761b59dfbea6bb121f39053cefcac20a984b8d3b SHA512 9ac5cd03b67731aba5371ec9edb3aabb7d3e3b3680552b14741106d8d5ffe5a1705ad379dd8df60b972f3e23f66ed35b98341544feb4b856912138ccac109660
-EBUILD ide-smart-1.4-r1.ebuild 566 BLAKE2B b08856a5cbf6468e7cc2d5b494de43bb6ce0df62bafaddf9dc47ba3435b7b6a2846919c0cc44545702e7c4c3bd158ccdc15b6d3fe5dff144696b76a33463d192 SHA512 b87246febf9a05bf567b355cb46a5e30d25bd85c05caf3331c0489e213a4ddcc8225a1654920c5ce0fcc69558693589c3e4ed39c329a84f45213262f162bfab6
+EBUILD ide-smart-1.4-r1.ebuild 691 BLAKE2B 365faf918071ed12a596f8cf029c6b9fdb5e76dee3e6dc0c0ba11fadf868aa2ab7c8ed8af06aa25b559e6a65f71dbecd606b9e3065aca481d8db49bfd679285e SHA512 6a54fb402a507937358b6ada716caf88e9335dd02c83cee489bb2c2dd026521361a2df821a1bea13dbd025929d318036ec1648135dbbee703b7c9e9d07f13ae1
EBUILD ide-smart-1.4-r2.ebuild 578 BLAKE2B 3e2a0f1117551cf82bb72af0f43f942ecf50aaaf624f772860f290cd708c5c6da12fb30c7a3eba05cbed211da60d7dbff94ede73a4e6b37c240e78425240e830 SHA512 73367fa4439efb9d52688da838416762119314f7545cde96973c1e14cb090d0497f4f8391bd9398cbbff0d8a15ad9fe409fb77fe341b4dae1fd568cb805571a8
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch b/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..ad523e36b3f9
--- /dev/null
+++ b/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
@@ -0,0 +1,17 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,13 +2,10 @@
+
+ #CC = gcc
+ PROF = -g0 -O2
+-CFLAGS = $(PROF) -Wall
+-LDFLAGS = $(PROF)
++CFLAGS += -Wall
+ TARGET = ide-smart
+ OBJECTS = ide-smart.o
+
+-ide-smart: $(OBJECTS)
+- $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS)
+
+ all: ide-smart
+
diff --git a/app-admin/ide-smart/ide-smart-1.4-r1.ebuild b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
index cac5d77934f3..5ffb6e04cbb2 100644
--- a/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
+++ b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="A tool to read SMART information from harddiscs"
@@ -12,12 +14,22 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-src_compile() {
- $(tc-getCC) ${CFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c || die "compile"
+PATCHES=( "${FILESDIR}"/${PN}-1.4-fix-build-system.patch )
+
+src_prepare() {
+ default
+
+ # yes, the tarball includes pre-compiled
+ # object files and binaries
+ rm ${PN}{,.o} || die
+}
+
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin ide-smart || die
+ dobin ide-smart
doman ide-smart.8
- dodoc README
+ einstalldocs
}