summaryrefslogtreecommitdiff
path: root/app-admin/ide-smart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-13 10:44:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-13 10:44:02 +0100
commit57dbe782fa3930bfa59520388f90ca4c2f037785 (patch)
treecab5bb5fd36f7758c6ba15635a713eadc3ee5754 /app-admin/ide-smart
parent7bb2a634b4e693c8545db3823c080e6edec25e77 (diff)
gentoo auto-resync : 13:09:2023 - 10:44:02
Diffstat (limited to 'app-admin/ide-smart')
-rw-r--r--app-admin/ide-smart/Manifest1
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r3.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-admin/ide-smart/Manifest b/app-admin/ide-smart/Manifest
index 7665ff70ce23..3ad9915848c4 100644
--- a/app-admin/ide-smart/Manifest
+++ b/app-admin/ide-smart/Manifest
@@ -1,3 +1,4 @@
DIST ide-smart-1.4.tar.gz 19739 BLAKE2B d9c94b53855628ea10ea563f709754e7f79e50d43e24f76ac3c6dc9b5bdee81a547e63c4583c3506cc899c7e761b59dfbea6bb121f39053cefcac20a984b8d3b SHA512 9ac5cd03b67731aba5371ec9edb3aabb7d3e3b3680552b14741106d8d5ffe5a1705ad379dd8df60b972f3e23f66ed35b98341544feb4b856912138ccac109660
EBUILD ide-smart-1.4-r2.ebuild 564 BLAKE2B 64cebd0eccd111e75441b2fca3704c9750fa1dacf6306174f13ced1531a3f98102edb83e1791350f734f17d0b747aa7e70344c6e59c4528d94cb7a2d94cb01b2 SHA512 49f08361338af6f339894529ac9b5371d55b24bf20b5a5567074bce10b65d0cd53848fa718391e715d0279fca276974372b37f46345c1584e78b26a89aacd3ae
+EBUILD ide-smart-1.4-r3.ebuild 563 BLAKE2B b78e6facddf881649cc9bb57179ac72de915c2a8115e5bcc5c5d1f980b4443802b7f938f599fdc085d53cf1c885b7ed8e04112c378c0bc69030f0d247001056c SHA512 eb771ee8d51f4aa593dc08559bbaaee98e7d847a46b3a5202e93a67b3ac514a051148d4137ad71e6fbdc8c4b3bce6912c68cc5c73064829211a609a465c99fbf
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-admin/ide-smart/ide-smart-1.4-r3.ebuild b/app-admin/ide-smart/ide-smart-1.4-r3.ebuild
new file mode 100644
index 000000000000..813ff8c814dc
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="A tool to read SMART information from harddiscs"
+HOMEPAGE="http://www.linalco.com/comunidad.html http://www.linux-ide.org/smart.html"
+SRC_URI="http://www.linalco.com/ragnar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_compile() {
+ edo $(tc-getCC) ${CFLAGS} ${CPPFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c
+}
+
+src_install() {
+ dobin ide-smart
+ doman ide-smart.8
+ dodoc README
+}