summaryrefslogtreecommitdiff
path: root/app-admin/haskell-updater/haskell-updater-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/haskell-updater/haskell-updater-1.3.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/haskell-updater/haskell-updater-1.3.1.ebuild')
-rw-r--r--app-admin/haskell-updater/haskell-updater-1.3.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/haskell-updater/haskell-updater-1.3.1.ebuild b/app-admin/haskell-updater/haskell-updater-1.3.1.ebuild
new file mode 100644
index 000000000000..5d51680239c9
--- /dev/null
+++ b/app-admin/haskell-updater/haskell-updater-1.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CABAL_FEATURES="bin nocabaldep"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
+HOMEPAGE="http://haskell.org/haskellwiki/Gentoo#haskell-updater"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.12.1"
+
+# Need a lower version for portage to get --keep-going
+RDEPEND="|| ( >=sys-apps/portage-2.1.6
+ sys-apps/pkgcore
+ sys-apps/paludis )"
+
+src_prepare() {
+ default
+
+ if use prefix; then
+ sed -i -e "s,/var/db/pkg,${EPREFIX}&,g" \
+ "${S}/Distribution/Gentoo/Packages.hs" || die
+
+ sed -i -e 's,"/","'"${EPREFIX}"'/",g' \
+ "${S}/Distribution/Gentoo/GHC.hs" || die
+ fi
+}
+
+src_configure() {
+ cabal_src_configure \
+ --bindir="${EPREFIX}/usr/sbin" \
+ --constraint="Cabal == $(cabal-version)"
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc TODO
+}