summaryrefslogtreecommitdiff
path: root/app-admin/gopass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-admin/gopass
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-admin/gopass')
-rw-r--r--app-admin/gopass/Manifest3
-rw-r--r--app-admin/gopass/gopass-1.8.3.ebuild43
-rw-r--r--app-admin/gopass/metadata.xml11
3 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/gopass/Manifest b/app-admin/gopass/Manifest
new file mode 100644
index 000000000000..9e05eede2059
--- /dev/null
+++ b/app-admin/gopass/Manifest
@@ -0,0 +1,3 @@
+DIST gopass-1.8.3.tar.gz 6374004 BLAKE2B 1f3b66e8a631d94fbbb33347009a4614f180d7bd30f3d73e98f476fc81a3f5f0aef15c80705b1b4e871f333a3366cc051eb41785082bb90420a5d34f38e35e16 SHA512 bcf8e4cdb37355ae43d0d6d21e3248d3547fb3f1892bb2e8d5d8ddc47a784f75f4f404429733ac824bd66d719fe63fef7a1d58facde65a6d1820ecf14e7bd77e
+EBUILD gopass-1.8.3.ebuild 1041 BLAKE2B 4fa9681eeb9b8c0b9be470cfc8fe3b3f2ef806e4b64238b412d67deb72bfff4cf9cc0bd4977028287ff6e5ce5fac26874925da6e181068c4c69555b3a7c4bfbc SHA512 1bbff9001cad0448f310a5db019117b13edc2c81a66025b10a0e491fc9f6d6f2bcc1837e5ffeae46705911aa7d8d4ba288efa92888fbfd3785805195733a7ed5
+MISC metadata.xml 326 BLAKE2B fbff56ecc7a4bd866c1220fc218f9233ed0660b04cde03047df5db992557bf5d20f518815dc15eba2a22f6b2b8cc4eb5ed1c0f2cc2753e18ce4cafd59b768637 SHA512 2d43a58c7997bd539d9aa5659fe7cfcd947c97c49d31dea4ee1230b06b0ae2c8cef4fb228b889968f65c36693d5befa76828da3644bea0852ead709bbf7d760c
diff --git a/app-admin/gopass/gopass-1.8.3.ebuild b/app-admin/gopass/gopass-1.8.3.ebuild
new file mode 100644
index 000000000000..1345581a840c
--- /dev/null
+++ b/app-admin/gopass/gopass-1.8.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/gopasspw/gopass"
+
+inherit golang-vcs-snapshot golang-build bash-completion-r1
+
+DESCRIPTION="a simple but powerful password manager for the terminal"
+HOMEPAGE="https://www.gopass.pw/"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.11"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"
+
+src_install() {
+ dobin gopass
+
+ local DOCS=( src/${EGO_PN}/{CHANGELOG,CONTRIBUTING}.md src/${EGO_PN}/docs/*.md )
+ einstalldocs
+
+ # install fish completion
+ ./gopass completion fish > "${T}"/${PN}.fish || die
+ insinto /usr/share/fish/vendor_completions.d
+ doins "${T}"/${PN}.fish
+
+ # install bash completion
+ ./gopass completion bash > "${T}"/${PN} || die
+ dobashcomp "${T}"/${PN}
+
+ # install zsh completion
+ ./gopass completion zsh > "${T}"/${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins "${T}"/${PN}.zsh _${PN}
+}
diff --git a/app-admin/gopass/metadata.xml b/app-admin/gopass/metadata.xml
new file mode 100644
index 000000000000..06eb97b4a0f0
--- /dev/null
+++ b/app-admin/gopass/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gopasspw/gopass</remote-id>
+ </upstream>
+</pkgmetadata>