summaryrefslogtreecommitdiff
path: root/app-admin/gnome-abrt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
commitaa3411e241a201d53a2689766fe419f2756819f3 (patch)
treecc19adfde0a10aab1ab566c8dfe3c1616e5cc390 /app-admin/gnome-abrt
parentb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (diff)
gentoo resync : 24.03.2019
Diffstat (limited to 'app-admin/gnome-abrt')
-rw-r--r--app-admin/gnome-abrt/Manifest2
-rw-r--r--app-admin/gnome-abrt/gnome-abrt-1.2.7.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/gnome-abrt/Manifest b/app-admin/gnome-abrt/Manifest
index 03efa0c28e3f..fcc889dfd5ab 100644
--- a/app-admin/gnome-abrt/Manifest
+++ b/app-admin/gnome-abrt/Manifest
@@ -1,4 +1,6 @@
AUX 0001-Remove-Expert-mode-and-the-remaining-Analyze-code.patch 4329 BLAKE2B 408bd52cd8a7ae8ae60a938da810a2af35556111791f330887d7c6f9af1f27eb50a4efa4f646144fb3e2483398f7e4af21afb4b587f6068a5764004d0efdfca4 SHA512 e7c505da3355a721c38d043fd0dc7397f664d90f1c243203a5055dfeefde7b8aafe02a8bd3acb22ba32941740e4aab38873fa75178ee1d4776a2da182e6b2033
DIST gnome-abrt-1.2.6.tar.gz 340308 BLAKE2B 5221fe43fd72fe8798f2c11275863e6936e616632641448c53dd24118d3b6b808fc373fe98b8775f1f1c58820c06195a665f6d417c95eaa7cc333cd7660b2d0b SHA512 12bcdeefa481b7caa04da046ee11d6adc9fd582b32f709d79a2d94cf61ca02643edd418cd9257c0f732a30aa5714fe83a282a4c794ff4260ddad038f7721ff2c
+DIST gnome-abrt-1.2.7.tar.gz 339961 BLAKE2B cdacc079c4661c364f13af3102e2231adbeaf4226ba937436f5ce3ae109f28b87c9424c6dfbc016b912599205386f92c32b036ca31adbea79b9a54d7f3a27c4a SHA512 57446b1c1c312f3a47ea3dd2a40ac1d4ec5392df3181eac73086675b65d45cad9a01fba5252d073970878ef97d7d272508bc5b86a56779543ffdc8d083fb5413
EBUILD gnome-abrt-1.2.6.ebuild 1306 BLAKE2B 27f2fafdb5fea0dbda5679ec9dcc75826e7a7a54af261f66c66466b85ec3a6bf271f3d16b2e745cf4d2e2b87215bfbb1d11aec7b095cad69d2072e67faca41c4 SHA512 b8efc525446bd3148f7a7059388e6c2ef90005e0b79a5fe282b46b635824f71bcb9e26347a61b366ea594e1ab559cbdd6b003c572b4f93ae474372a87ebfe026
+EBUILD gnome-abrt-1.2.7.ebuild 1305 BLAKE2B 42e9162c76603f51bd26418689ce89560dbe756a0afa86d840d7aaf864141b3470a601726d85c35a8343e4a15504d91f41389256ff3ed002f3d217e6bb143e05 SHA512 c48eedd9c4148232f510d813acbe51679ddb1d637dba3937ed6bacf734ba34a95bb456f7152dedea3e93e63be0f5baa20dfff166db5c079a3d38b0155bf4164d
MISC metadata.xml 333 BLAKE2B 7dfc442159eac1c4501c5bfaeec34615e2e8dd63b982759f30a0835143a1d5b661cce8e85868be70115c93c26f7ed70389b9f7ad6ae88f93b081f126c42beef3 SHA512 8c2e01101d19e3cd8ade5da1921864d2103eaa2f140c0eccb398e2567254d839311ba1384e25e0bea316345943c0649aee92aabb3ec2092d1a9e0728436fadc4
diff --git a/app-admin/gnome-abrt/gnome-abrt-1.2.7.ebuild b/app-admin/gnome-abrt/gnome-abrt-1.2.7.ebuild
new file mode 100644
index 000000000000..a0fb1a7815e3
--- /dev/null
+++ b/app-admin/gnome-abrt/gnome-abrt-1.2.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit autotools python-r1
+
+DESCRIPTION="A utility for viewing problems that have occurred with the system"
+HOMEPAGE="https://github.com/abrt/gnome-abrt"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.10.0:3
+ >=dev-libs/libreport-2.0.20[python,${PYTHON_USEDEP}]
+ >=app-admin/abrt-2.10.10-r1
+ >=dev-python/pygobject-3.29.1:3[${PYTHON_USEDEP}]
+ x11-libs/libX11
+ >=dev-python/pyxdg-0.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+src_prepare() {
+ default
+ ./gen-version > gnome-abrt-version || die
+ eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ myeconfargs=(
+ --localstatedir="${EPREFIX}/var"
+ --with-nopylint
+ )
+
+ python_foreach_impl run_in_build_dir econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ find "${D}" -name '*.la' -type f -delete || die
+}