summaryrefslogtreecommitdiff
path: root/app-admin/gnome-abrt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/gnome-abrt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/gnome-abrt')
-rw-r--r--app-admin/gnome-abrt/Manifest4
-rw-r--r--app-admin/gnome-abrt/files/0001-Remove-Expert-mode-and-the-remaining-Analyze-code.patch108
-rw-r--r--app-admin/gnome-abrt/gnome-abrt-1.2.6.ebuild67
-rw-r--r--app-admin/gnome-abrt/metadata.xml11
4 files changed, 190 insertions, 0 deletions
diff --git a/app-admin/gnome-abrt/Manifest b/app-admin/gnome-abrt/Manifest
new file mode 100644
index 000000000000..03efa0c28e3f
--- /dev/null
+++ b/app-admin/gnome-abrt/Manifest
@@ -0,0 +1,4 @@
+AUX 0001-Remove-Expert-mode-and-the-remaining-Analyze-code.patch 4329 BLAKE2B 408bd52cd8a7ae8ae60a938da810a2af35556111791f330887d7c6f9af1f27eb50a4efa4f646144fb3e2483398f7e4af21afb4b587f6068a5764004d0efdfca4 SHA512 e7c505da3355a721c38d043fd0dc7397f664d90f1c243203a5055dfeefde7b8aafe02a8bd3acb22ba32941740e4aab38873fa75178ee1d4776a2da182e6b2033
+DIST gnome-abrt-1.2.6.tar.gz 340308 BLAKE2B 5221fe43fd72fe8798f2c11275863e6936e616632641448c53dd24118d3b6b808fc373fe98b8775f1f1c58820c06195a665f6d417c95eaa7cc333cd7660b2d0b SHA512 12bcdeefa481b7caa04da046ee11d6adc9fd582b32f709d79a2d94cf61ca02643edd418cd9257c0f732a30aa5714fe83a282a4c794ff4260ddad038f7721ff2c
+EBUILD gnome-abrt-1.2.6.ebuild 1306 BLAKE2B 27f2fafdb5fea0dbda5679ec9dcc75826e7a7a54af261f66c66466b85ec3a6bf271f3d16b2e745cf4d2e2b87215bfbb1d11aec7b095cad69d2072e67faca41c4 SHA512 b8efc525446bd3148f7a7059388e6c2ef90005e0b79a5fe282b46b635824f71bcb9e26347a61b366ea594e1ab559cbdd6b003c572b4f93ae474372a87ebfe026
+MISC metadata.xml 333 BLAKE2B 7dfc442159eac1c4501c5bfaeec34615e2e8dd63b982759f30a0835143a1d5b661cce8e85868be70115c93c26f7ed70389b9f7ad6ae88f93b081f126c42beef3 SHA512 8c2e01101d19e3cd8ade5da1921864d2103eaa2f140c0eccb398e2567254d839311ba1384e25e0bea316345943c0649aee92aabb3ec2092d1a9e0728436fadc4
diff --git a/app-admin/gnome-abrt/files/0001-Remove-Expert-mode-and-the-remaining-Analyze-code.patch b/app-admin/gnome-abrt/files/0001-Remove-Expert-mode-and-the-remaining-Analyze-code.patch
new file mode 100644
index 000000000000..21d088efab4f
--- /dev/null
+++ b/app-admin/gnome-abrt/files/0001-Remove-Expert-mode-and-the-remaining-Analyze-code.patch
@@ -0,0 +1,108 @@
+From ab72d64818a5d88ceb4ab94f1eaae04268519e73 Mon Sep 17 00:00:00 2001
+From: Rafal Luzynski <digitalfreak@lingonborough.com>
+Date: Mon, 21 Aug 2017 11:55:41 +0200
+Subject: [PATCH] Remove Expert mode and the remaining Analyze code
+
+The Expert mode was originally introduced together with the Analyze
+feature by the commit 532cbd4. The Expert mode was intended to hide
+the Analyze feature by default and show in only when the Expert mode
+is on. Later the commit f5eb93f removed most of the Analyze feature
+although some of its code still remained and was unused. At the same
+time, probably by mistake, the Expert mode was switched to control
+the visibility of the Details context menu item.
+
+This commit removes the Expert mode which is unused and implemented
+incorrectly and any remains of the Analyze feature. Closes #182.
+---
+ src/gnome-abrt | 3 ---
+ src/gnome_abrt/controller.py.in | 7 -------
+ src/gnome_abrt/oops.glade | 8 --------
+ src/gnome_abrt/views.py | 7 -------
+ 4 files changed, 25 deletions(-)
+
+diff --git a/src/gnome-abrt b/src/gnome-abrt
+index f8e96e8..b1044d3 100755
+--- a/src/gnome-abrt
++++ b/src/gnome-abrt
+@@ -401,8 +401,6 @@ if __name__ == "__main__":
+ help=_('Be verbose'))
+ CMDARGS.add_argument('-p', '--problem',
+ help=_('Selected problem ID'))
+- CMDARGS.add_argument('-x', '--expert', action='store_true',
+- help=_('Expert mode'))
+
+ OPTIONS = CMDARGS.parse_args()
+
+@@ -414,7 +412,6 @@ if __name__ == "__main__":
+ CONF = get_configuration()
+ # TODO : mark this option as hidden or something like that
+ CONF.add_option('problemid', default_value=None)
+- CONF.add_option('expert', default_value=(OPTIONS.expert))
+
+ APP_CMDLINE = []
+ if 'problem' in VARS:
+diff --git a/src/gnome_abrt/controller.py.in b/src/gnome_abrt/controller.py.in
+index fc16dc2..86db419 100644
+--- a/src/gnome_abrt/controller.py.in
++++ b/src/gnome_abrt/controller.py.in
+@@ -45,13 +45,6 @@ class Controller(object):
+
+ problem.delete()
+
+- def analyze(self, problem):
+- if not problem:
+- logging.error("BUG: Controller: Can't open detail of None problem")
+- return
+-
+- self.run_event_fn("open-gui", problem)
+-
+ def _refresh_sources(self):
+ for name, src in self.sources:
+ try:
+diff --git a/src/gnome_abrt/oops.glade b/src/gnome_abrt/oops.glade
+index bbb732b..b8ddb42 100644
+--- a/src/gnome_abrt/oops.glade
++++ b/src/gnome_abrt/oops.glade
+@@ -23,14 +23,6 @@
+ <accelerator key="Return"/>
+ </child>
+ <child>
+- <object class="GtkAction" id="gac_analyze">
+- <property name="label" translatable="yes">Analy_ze</property>
+- <property name="tooltip" translatable="yes">Open selected problem for analysis</property>
+- <signal name="activate" handler="on_gac_analyze_activate" swapped="no"/>
+- </object>
+- <accelerator key="Return" modifiers="GDK_CONTROL_MASK | GDK_MOD1_MASK"/>
+- </child>
+- <child>
+ <object class="GtkAction" id="gac_detail">
+ <property name="label" translatable="yes">D_etails</property>
+ <property name="tooltip" translatable="yes">Show technical details</property>
+diff --git a/src/gnome_abrt/views.py b/src/gnome_abrt/views.py
+index 82b606f..ec7b211 100644
+--- a/src/gnome_abrt/views.py
++++ b/src/gnome_abrt/views.py
+@@ -527,7 +527,6 @@ class OopsWindow(Gtk.ApplicationWindow):
+ conf.set_watch('T_FMT', self._options_observer)
+ conf.set_watch('D_T_FMT', self._options_observer)
+ self._options_observer.option_updated(conf, 'problemid')
+- self._builder.mi_detail.set_visible(conf['expert'])
+
+ # enable observer
+ self._source_observer.enable()
+@@ -1002,12 +1001,6 @@ _("This problem has been reported, but a <i>Bugzilla</i> ticket has not"
+ selected[0].problem_id, self)
+
+ @handle_problem_and_source_errors
+- def on_gac_analyze_activate(self, action):
+- selected = self._get_selected(self.lss_problems)
+- if selected:
+- self._controller.analyze(selected[0])
+-
+- @handle_problem_and_source_errors
+ def on_gac_report_activate(self, action):
+ selected = self._get_selected(self.lss_problems)
+ if selected and not selected[0]['not-reportable']:
+--
+2.13.6
+
diff --git a/app-admin/gnome-abrt/gnome-abrt-1.2.6.ebuild b/app-admin/gnome-abrt/gnome-abrt-1.2.6.ebuild
new file mode 100644
index 000000000000..5121f602279e
--- /dev/null
+++ b/app-admin/gnome-abrt/gnome-abrt-1.2.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools gnome2-utils python-single-r1
+
+DESCRIPTION="A utility for viewing problems that have occurred with the system"
+HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ x11-libs/gtk+:3
+ >=dev-libs/libreport-2.0.20[python]
+ >=app-admin/abrt-2.10.10-r1
+ dev-python/pygobject:3
+ x11-libs/libX11
+ >=dev-python/pyxdg-0.19
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+PATCHES=(
+ # From Fedora (fixed in next release)
+ "${FILESDIR}"/0001-Remove-Expert-mode-and-the-remaining-Analyze-code.patch
+)
+
+src_prepare() {
+ default
+ ./gen-version > gnome-abrt-version || die
+ eautoreconf
+}
+
+src_configure() {
+ myeconfargs=(
+ --localstatedir="${EPREFIX}/var"
+ --with-nopylint
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-admin/gnome-abrt/metadata.xml b/app-admin/gnome-abrt/metadata.xml
new file mode 100644
index 000000000000..fec665753243
--- /dev/null
+++ b/app-admin/gnome-abrt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">abrt/gnome-abrt</remote-id>
+ </upstream>
+</pkgmetadata>