summaryrefslogtreecommitdiff
path: root/app-admin/gixy/gixy-0.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /app-admin/gixy/gixy-0.1.5.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'app-admin/gixy/gixy-0.1.5.ebuild')
-rw-r--r--app-admin/gixy/gixy-0.1.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/gixy/gixy-0.1.5.ebuild b/app-admin/gixy/gixy-0.1.5.ebuild
new file mode 100644
index 000000000000..4ade6ac258d8
--- /dev/null
+++ b/app-admin/gixy/gixy-0.1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx configuration static analyzer"
+HOMEPAGE="https://github.com/yandex/gixy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+python_prepare() {
+ sed -i -e "/argparse/d" setup.py || die
+ distutils-r1_python_prepare_all
+}